Fordmods Logo

El wont rev past 5k rpm 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: El wont rev past 5k rpm
Posted: Sat Jun 07, 2014 3:53 pm 
Oompa Loompa
Offline

Age: 22

Posts: 48

Joined: 26th May 2014

Ride: EL Futura

Location: Logan
QLD, Australia

Alright so the aux shaft went in my el falcon. Got it replaced and after taking my car to the track, I've found it hits limiter at about 5k rpm instead of close to 6k. Anyone know what's going on? Thanks
Top
 Profile  
 
 
 Post subject: Re: El wont rev past 5k rpm
Posted: Sun Jun 08, 2014 7:38 pm 
Getting Side Ways
Offline
User avatar

Age: 23

Posts: 461

Joined: 31st Mar 2013

Ride: 96 EL XR6

Location: Hervey Bay
QLD, Australia

If its standard there is no reason to be reving the poor i6 that high, i doubt it will be making any power, So your reving the sh!t out if it for no reason.

 

_________________

EL XR6, T5 Speed - Full Factory Fitted Tickford Body Kit, AU Engine, Billet Camtech 845 Cam, J3 Chip, MLS Gasket, Intake, Extractors, High flow cat, 2 1/2in exhaust, K&N Air Filter, 3.45 LSD, - My Pride and Joy

Top
 Profile  
 
 
 Post subject: Re: El wont rev past 5k rpm
Posted: Tue Jun 10, 2014 2:11 pm 
Oompa Loompa
Offline

Age: 22

Posts: 48

Joined: 26th May 2014

Ride: EL Futura

Location: Logan
QLD, Australia

Nah its not stock, hauls a** right to 6k limiter. Fixed it anyway
Top
 Profile  
 
 
 Post subject: Re: El wont rev past 5k rpm
Posted: Tue Jun 10, 2014 6:15 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

sliding6 wrote:
Nah its not stock, hauls a** right to 6k limiter. Fixed it anyway


Well?

What was it?
Top
 Profile  
 
 
 Post subject: Re: El wont rev past 5k rpm
Posted: Tue Jun 10, 2014 8:27 pm 
Oompa Loompa
Offline

Age: 22

Posts: 48

Joined: 26th May 2014

Ride: EL Futura

Location: Logan
QLD, Australia

When the mechanics took the motor out to do the aux shaft, they have unplugged all the gearbox wiring and when they plugged it back in they havent plugged the speedo wire back in (5 speed conversion and wiring is a MESS).Because i didnt have any speedo when I picked it up and was hitting limiter at about 5k rpm. Then when I plugged the speedo back in it would rev to limiter at about 6k rpm again. Weird as
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 10:24 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names