Fordmods Logo

El Xr6 O2 Sensor location 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: El Xr6 O2 Sensor location
Posted: Thu Jul 28, 2016 8:10 pm 
Parts Gopher
Offline

Posts: 81

Joined: 22nd Nov 2010

Gallery: 1 images

Ride: EL XR6

Location: Auckland
New Zealand

My el xr6 felt sluggish off the line and had a bad stutter when accelerating off idle then the distributor failed so replaced that and found the cap and rotor were in very bad shape as well as the hall sensor failing after that things improved alot but it still feel a bit sluggish at low rpm and it feels like its got a miss ever few seconds. Ive installed aftermarket extractors and the o2 sensor (which i replaced when i did the dizzy) is only sensing off 3 cylinders instead of all 6 like it would from the factory. Would this be likley to be causing me any issues or does it not matter?

Edit: i installed the headers before the dizzy failed so im not sure what it would have been like with a good dizzy and the factory manifold.
Top
 Profile  
 
 
 Post subject: Re: El Xr6 O2 Sensor location
Posted: Fri Jul 29, 2016 3:56 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11640

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

EF_nut wrote:
My el xr6 felt sluggish off the line and had a bad stutter when accelerating off idle then the distributor failed so replaced that and found the cap and rotor were in very bad shape as well as the hall sensor failing after that things improved alot but it still feel a bit sluggish at low rpm and it feels like its got a miss ever few seconds. Ive installed aftermarket extractors and the o2 sensor (which i replaced when i did the dizzy) is only sensing off 3 cylinders instead of all 6 like it would from the factory. Would this be likley to be causing me any issues or does it not matter?

Edit: i installed the headers before the dizzy failed so im not sure what it would have been like with a good dizzy and the factory manifold.


I wouldn't think the O2 would play much of a role with car performance. It is used to detect levels of O2 in your exhaust and adjust the fuel/air mixture.

Have you checked/replaced your spark plug leads? They could be faulty causing poor spark and under load can fail and give you a miss.

Check for a vacuum leak some where.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: El Xr6 O2 Sensor location
Posted: Fri Jul 29, 2016 10:53 pm 
Technical Contributor
Offline
User avatar

Age: 52

Posts: 5524

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

Plus I'd be checking the timing is set correctly post the dizzy replacement.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: Alexa [Bot] and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Mar 25, 2017 7:07 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names