Fordmods Logo

engine dying at cruise, fuel related I think 

 

Page 3 of 3 [ 34 posts ] Go to page Previous  1, 2, 3

 
Posted: Fri Jun 23, 2006 7:14 pm 
Getting Side Ways
Offline
User avatar

Posts: 1549

Joined: 27th Apr 2005

Gallery: 1 images

Ride: AU Fairmont Ghia

Location: Perth
WA, Australia

it drops, wavers a bit, revs up, drops again, then it could either die or recover always around or below 1500 RPM never when developing power.

Injectors?
Top
 Profile  
 
 
Posted: Fri Jun 23, 2006 7:54 pm 
Oompa Loompa
Offline
User avatar

Age: 30

Posts: 42

Joined: 23rd Jan 2006

Location: Forrestfield
WA, Australia

i had similiar troubles randomly dying at low RPM, eventually it would barely run, then wouldnt start..., poor earth from negative to body, just replaced the terminal and the cable

 

_________________

Image

1993 EB GL Falcon 4.0L

Top
 Profile  
 
 
Posted: Fri Jun 23, 2006 8:42 pm 
Getting Side Ways
Offline
User avatar

Posts: 1549

Joined: 27th Apr 2005

Gallery: 1 images

Ride: AU Fairmont Ghia

Location: Perth
WA, Australia

the problem isnt as bad as it was before i replaced the TFI if that helps.

cardinal, will check everything
Top
 Profile  
 
 
Posted: Fri Jun 23, 2006 9:20 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 1001

Joined: 5th Nov 2004

Gallery: 19 images

Ride: EL Fairmont Ghia

Power: 132 rwkw

Location: Brisbane
QLD, Australia

mine used to die on a right hand corner but that was my fault as when i pulled the fuel pump out i didnt stick the pump back in the little reservior in the tank heh.

 

_________________

175.7hp 15.5 @ 374,000km
Team I have two E-Series AND all my teeth.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 3 of 3  [ 34 posts ]  Go to page Previous  1, 2, 3

Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 11:36 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names