Fordmods Logo

Engine miss fire 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: Engine miss fire
Posted: Sat Feb 23, 2019 5:04 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 18

Joined: 18th Mar 2017

Ride: Ford AU wagon series III

Location: orange
NSW, Australia

I have an au wagon series dedicated LPG. It's developed a miss fire. I have changed plugs swapped leads over and replaced the coil pack but nothing had changed. it started a couple of days ago I turned a corner and went through a puddle that came up over the LHS quarter panel. The car then stalled and eventually started again but was back firing. It has broken the air intake when it was backfiring and has been miss firing ever since.
Top
 Profile  
 
 
 Post subject: Re: Engine miss fire
Posted: Sun Feb 24, 2019 8:47 am 
Fordmods Junkie
Online
User avatar

Posts: 3020

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

Hi, possibly got water in a plug somewhere. will either need to air blow it out or use a water repellent spray.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Mar 20, 2019 7:01 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names