Fordmods Logo

Fordmods Advertising

engine problems 


Page 1 of 1 [ 3 posts ] 

 Post subject: engine problems
Posted: Mon Aug 22, 2005 6:43 pm 
Getting Side Ways
User avatar

Age: 30

Posts: 2754

Joined: 14th Apr 2005

Ride: fairmont

Location: mackay
QLD, Australia

hey all , i seem to have a problem with my ed fairmont, there seems to be some oily substance coming out from the engine on the left hand side and was curious if anybody can help, there is still oil in the car, and water and also the temp doesnt move from it is normally is, i was thinking it was the exhuast gasket dies it sound right??



Now i have a EF XR8 5spd.........mmmmmm 5L

Posted: Mon Aug 22, 2005 6:46 pm 
Fordmods Junkie
User avatar

Age: 37

Posts: 5051

Joined: 5th Nov 2004

Ride: Kia Rio - 1.4L Auto

Power: 238 rwkw

Location: Westside
VIC, Australia

If its oil on the exhaust side, it could be either the seal at the top of the timing cover, or the chain tensioner seal.

I'd say possibly tensioner seal first. They get brittle over time and leak.

Both areas are covered by the power steering pump, so you'd have to get that off first to inspect where the oil might be coming from.

When this seal was leaking on my EL, I had oil all down the front over the water pump and marks all the way back to the engine mount, down the side of the block.
Posted: Tue Aug 23, 2005 1:09 am 
Technical Contributor
User avatar

Posts: 2799

Joined: 6th Nov 2004

Gallery: 7 images

Ride: Falcon

Location: Sydney
NSW, Australia

oil in the car and water? what do you mean by that? try tracing it back to where its coming from, and if you don't know what it is, take a picture of the suspect, and post it up here.





Cheap, fast and reliable.. choose 2.

Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 30 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sun Oct 23, 2016 5:26 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names