Fordmods Logo

Engine suddenly cut out 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: Engine suddenly cut out
Posted: Thu Oct 29, 2015 7:37 am 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

Has this happened to anyone else?

On the way to work this morning, the engine of my EF just stalled. I was cruising in Drive at about 1600rpm, 60km/h, light throttle, and the engine stopped. I pulled over and, after about 5 seconds of cranking, the engine restarted, but stalled again. I turned the key off and back on again and could hear the fuel pump priming like normal. It restarted and ran fine the rest of the way to work, about 5 minutes - no issues, no loss of power or poor idle or anything.

Otherwise, the car has been running really sweet. This hasn't happened before; though I have had near total failures twice before and had to limp the car home, keeping the revs up. It was the ECU in both cases. I replaced the ECU about three months ago because of such a failure. But an ECU failure doesn't tend to "come right" like this. I run a J3 chip, but removing it doesn't fix an ECU failure. I keep a spare ECU and tools in the car now, so I can replace it in a couple minutes if it fails again.

Any suggestions would be appreciated. I dread the thought of it dying in the middle of the highway during rush hour (has happened once before in the middle of the main interchange - not fun :shock: ).

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: Engine suddenly cut out
Posted: Thu Oct 29, 2015 12:36 pm 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Is your J3 actually taped "in" - on my car, if I give the chip a good knock it will stall and it will be key off before key back on.

Also - Fuel pump would do this is intermittent.

And... its an EF. Smartlock module failure would do this. If your already running a J3, perhaps disable smartlock as extra insurance?

Nigel
Top
 Profile  
 
 
 Post subject: Re: Engine suddenly cut out
Posted: Thu Oct 29, 2015 5:10 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

Hi Nigel,

Good ideas. I have taped the chip in, but should double-check the contacts in case there is corrosion or it is not seated properly.

I think fuel pumps tend to die and stay dead, but have heard of cases where they get intermittent.

Never thought about smartlock. Do I simply switch off the smartlock enable in the tune? Are there any side effects of doing this?

Thanks for the tips.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: Engine suddenly cut out
Posted: Thu Oct 29, 2015 5:36 pm 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Howdy.

Switching Smartlock off should have no repercussions - oh except that you will lack the imobiliser ;).

The Fuel pumps are often intermittent - thats my usual failure - and many people here are able to get the pump "rolling" again by hitting it from under the tank - but the advice is to drive straight home and fit a new one...

Could be many other things of course. MAP Sensor line to manifold disconnected, fuel pump relay, eec relay - but the fuel pump is my first port of call.

Nigel
Top
 Profile  
 
 
 Post subject: Re: Engine suddenly cut out
Posted: Thu Oct 29, 2015 9:17 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5587

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

A simple way to run the pump and test the associated wiring and relays is to turn IGN on, with the top right diagnosis pin earthed. If everything is okay, the pump will run continuously with the engine off.
In tunerpro, yes, uncheck the smartlock enable box. Correct me if I'm wrong, smartlock is only in play during starting - while running, it has no effect.

Given the age of these ECU's, I've found them quite reliable - provided they're kept away from moisture, etc.
I was running a J3 chip that at times the car would run crap and die - no restart - pull the chip and car is normal again. Refit chip later and it would run okay again, so I'd go with bad contacts.

I'm running another of my J3 chips without issue, and the troublesome one is running in another car without issue - go figure :?:

If you can, pull the ECU codes, even from the supposed dead ECU's. Check your crank angle sensor - oil, rubbish can give issues - either connection wise, or the pickup end - no CAS means dead car too.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
 Post subject: Re: Engine suddenly cut out
Posted: Tue Nov 17, 2015 6:13 am 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

UPDATE

The problem seems to be solved.

A pattern was emerging: it would only happen in the mornings, the first trip of the day, never any other time. It wasn't just temperature, as the mornings are warmer than they have been during the winter. So, it must be something happening overnight. As it's very humid here, I suspected moisture condensing in the tank and being sucked through the fuel system. So, I put 200mls of methylated spirits (and a bottle of injector cleaner) in the fuel to absorb the water.

To cover all the bases, I also swapped the ECU with another I had on the shelf, and swapped in a new J3 chip I had (waiting to go into my AU) with same tune.

It's been a week and a half with no issues, so it seems to be fixed. Thanks for all the advice.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: Engine suddenly cut out
Posted: Tue Nov 17, 2015 6:13 am 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 2:59 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names