Fordmods Logo

Falcon dying... need help! 


Page 1 of 1 [ 5 posts ] 

 Post subject: Falcon dying... need help!
Posted: Wed Nov 04, 2009 6:58 pm 
Fordmods Newbie

Age: 28

Posts: 1

Joined: 4th Nov 2009

Ride: 01 SR Falcon

Location: Brisbane
QLD, Australia

Hey all, my first post under this account (i used to have another account but forgot the login) Good to see the site is still going strong!.


I have a 2001 SR falcon (i think thats au2) has around 230xxx k's on it now.

It has been slowly dying lately, just wondering if theres a trend with these issues? That are pointing to one thing i can fix.

I had a problem with the engine missing, so i got new spark plugs when i got a service, and it worked fine for about 2 weeks and then it gradually came back. Last time i had this issue i got new leads and plugs and it didnt miss a beat for about a 1.5 years after that. Im thinking its maybe the leads?

Shortly after that my left window decided to start jamming, but has since allowed me to wind it up and down now from time to time.

Then the speedo decided to die, closely followed by the electric km remaining prediction thing. Although everything else still works? When i fill the car it tells me how many k's are left but then the reading wont go down. Although the fuel gauge still works?

Strange? Any help is appreciated.

Thanks in advance.

 Post subject: Re: Falcon dying... need help!
Posted: Thu Nov 05, 2009 12:15 am 
Fordmods Newbie
User avatar

Age: 24

Posts: 16

Joined: 4th Nov 2009

Ride: AU Fairmont

Location: Broome
WA, Australia

mate i have no idea how to fix it, but i sympathise with ur cause haha, mines a '99 Fairmont an my electrics are shot too; windows, dash, aircond display etc.

even the map lights dont work an i cant b a*** fixin them haha.

havnt been havin engine problems tho...

let me know if u find out wats wrong
 Post subject: Re: Falcon dying... need help!
Posted: Tue Nov 10, 2009 11:06 am 
Oompa Loompa
User avatar

Age: 31

Posts: 48

Joined: 16th Oct 2006

Gallery: 1 images

Ride: Au series 3, 12/92 nc fairlane

Location: adelaide
SA, Australia

hi for the speedo and tripmeter check the cables on the side of the trans if they are oily or not making good contact it will give problems. in my ea1 the speedo would only work when it felt like it but i removed the trans to fix the front seal and cleaned the plugs (read whole trans was black) when i bolted it al back together havent had a problem since now the engine is dying slowly time for new ea
 Post subject: Re: Falcon dying... need help!
Posted: Sat Nov 28, 2009 12:48 pm 
Stock as a Rock

Posts: 165

Joined: 2nd Feb 2007

Ride: Ford AU series 2 Wagon

Location: melbourne
VIC, Australia

sounds like a electrical short circuit get a sparky to look at it




 Post subject: Re: Falcon dying... need help!
Posted: Sat Nov 28, 2009 1:35 pm 
NSW Cruise Moderator
User avatar

Age: 38

Posts: 7330

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

if the leads and plugs are still in good order, I would be looking at the coil pack, 1 coil fires 2 cylinders, so if you have a miss on 2, 1 coil could be failing. The miss would be more obvious under load as well with a failing coil pack. Plugs and leads a re cheaper and easier to replace than a stuffed coil pack though, so I would be doing them first. have you checked all the leads for consistant spark?

Lights going out on the various parts on the dash, windows being intermitant and guages failing to work consistantly would make me lean towards the BEM either not being plugged in properly or starting to fail. Hope this helps and gives you a starting point at least.





I have a car.

Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Thu Oct 27, 2016 2:52 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names