Fordmods Logo

Fifure this out for me... 


Page 1 of 1 [ 5 posts ] 

 Post subject: Fifure this out for me...
Posted: Wed Jun 21, 2006 1:05 pm 
Stock as a Rock

Age: 28

Posts: 144

Joined: 1st Jun 2006

Gallery: 1 images

Ride: EL XR6

Location: yarrawonga
VIC, Australia

ATM, my engine is into holding up revs. i dont know what it is but even when its cold around the 200-2500 mark it seems to slow down in its return to normal idle. below and above it it is alot better and from 1500 it just drops straight off. i have had it tested and they thought it was an intake gasket. had that replaced, he told me to come back in 2 weeks, its now been a bit over and the f****** thing is still doing it. i dont know whether its a sensor or the computer is getting the wrong signal but i noticed it ever since i got my exhaust. a mate has another with the same system and his has no troubles. its really sh***** me up the wall because no one can tell me whats wrong with it. oh the engine has done just on 114,500 kms so its got plenty left in it, fuel economy aint as good as i had hoped so maybe its getting too much fuel or the computer thinks its running lean for that revs and tryin to flod the injectors... who knows... anyway any help or suggestions would be greatly appreciated



EL XR6, 5 Speed Manual, Extractors, Exhaust, 3" Intake, EL GT Intake, Alpine sound system,lowered, 136rwkw.. to come.. another sub and boot install

Posted: Wed Jun 21, 2006 1:15 pm 
Getting Side Ways
User avatar

Age: 51

Posts: 4370

Joined: 5th Nov 2004

Ride: BA Fairlane Ghia

Location: Karratha
WA, Australia

Have you pulled the codes from the ECU? might give you a clue.
Posted: Wed Jun 21, 2006 1:40 pm 
Parts Gopher

Age: 69

Posts: 55

Joined: 19th Mar 2005

Location: sydney
NSW, Australia

Try resetting ECU, but it seems to take about 200-300 k's before it "learns" new hardware.
Posted: Wed Jun 21, 2006 7:53 pm 
Getting Side Ways
User avatar

Age: 40

Posts: 2893

Joined: 24th May 2006

Gallery: 21 images

Ride: XH B&S ute, Navara 4x4

Power: 202 rwkw

Location: Bordertown
SA, Australia

Sounds like the idle control sensor on the power steeri ng rack. It is located pretty much straight under the exhaust manifold on the end of the rack.



You'll ride a black tornado across the western sky

You'll rope an ol' blue norther and milk it 'till it's dry

Bulldog the Diamantina pin its ears down flat

Long before you take this cowboy's hat

Posted: Wed Jun 21, 2006 8:06 pm 
Technical Contributor
User avatar

Age: 37

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

clean the ISC
its noted in this section

good luck!



Carefree, we may not be number one, but we're up there.

Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google [Bot], MSNbot Media and 9 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 29, 2016 7:03 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names