Fordmods Logo

flat battery or failing starter motor? 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: flat battery or failing starter motor?
Posted: Sat Apr 17, 2010 7:31 pm 
Tyre Shredder
Offline
User avatar

Age: 29

Posts: 321

Joined: 17th Nov 2009

Gallery: 1 images

Ride: BF XT Falcon

Location: Melbourne
VIC, Australia

hey all. Tried to fire the car up today before pulling it appart. its been sitting for a few months. When i tried to turn it over it made really loud click click click sounds. what does that mean?
Top
 Profile  
 
 
 Post subject: Re: flat battery or failing starter motor?
Posted: Sat Apr 17, 2010 7:32 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

if its been sitting a while i would say your battery is probably flat.???
Top
 Profile  
 
 
 Post subject: Re: flat battery or failing starter motor?
Posted: Sat Apr 17, 2010 7:45 pm 
Smokin em up
Offline
User avatar

Age: 40

Posts: 248

Joined: 4th Nov 2007

Gallery: 1 images

Ride: AUIII

Location: COONABARABRAN
NSW, Australia

^^^^ yep battery for sure.


MITCHY

 

_________________

AUIII, PACEY 4499's, MAGNIFLOW CAT, 2.5" ZORST, 17X8" AUII XR RIMS....otherwise all factory!

Top
 Profile  
 
 
 Post subject: Re: flat battery or failing starter motor?
Posted: Sat Apr 17, 2010 8:35 pm 
Parts Gopher
Offline

Age: 38

Posts: 95

Joined: 31st Jan 2010

Gallery: 33 images

Ride: 96 Ford Fairmont EF II n others

Location: Kingston
QLD, Australia

^^^as they said battery for sure....even tap the starter solanoid just incase but id say battery :)

 

_________________

Lowndes,wincup & courtney ..Number 1 Tr888tors.....bring Ambrose back

Top
 Profile  
 
 
 Post subject: Re: flat battery or failing starter motor?
Posted: Sat Apr 17, 2010 8:49 pm 
Tyre Shredder
Offline
User avatar

Age: 29

Posts: 321

Joined: 17th Nov 2009

Gallery: 1 images

Ride: BF XT Falcon

Location: Melbourne
VIC, Australia

thanks, will try jumping it once the cars all back together
Top
 Profile  
 
 
 Post subject: Re: flat battery or failing starter motor?
Posted: Sun Apr 18, 2010 11:51 am 
Parts Gopher
Offline

Age: 56

Posts: 82

Joined: 31st Aug 2007

Ride: 98 EL GLI

Location: Adelaide
SA, Australia

Is prob the battery as others have said. But try turning the headlights on and then trying to start the car. If you hear the clicks and the headlights dim right down it's the battery odds on. If you hear the clicks and the headlights stay fairly bright, check the stater out
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: Google [Bot], mav666 and 27 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 1:55 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names