Fordmods Logo

Ford Falcon ef 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Ford Falcon ef
Posted: Fri Sep 22, 2017 6:35 pm 
Fordmods Newbie
Offline

Age: 44

Posts: 2

Joined: 22nd Sep 2017

Ride: Ford Falcon ef

Location: Melbourne
VIC, Australia

Hey,
Ford falcon ef when gets hot, economy light stays on blows lots of smoke,no power, fans working flat out. Something gets stuck even when cools down still all the above happens. Then next day back to running beautiful. Happens every so often.Pulled the fan fuse out to listen while engine is off and keeps priming.
Top
 Profile  
 
 
 Post subject: Re: Ford Falcon ef
Posted: Wed Sep 27, 2017 11:42 am 
Getting Side Ways
Offline

Posts: 833

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

Fans running constantly usually means an ECU issue.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: Ford Falcon ef
Posted: Wed Sep 27, 2017 3:22 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11723

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Your auto box might be overheating which causes the thermo fans to run constantly to help cool it down. Have you checked your coolant level? Hopefully it's still green/clear, rather than brownie/red.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: Ford Falcon ef
Posted: Wed Sep 27, 2017 7:09 pm 
Fordmods Newbie
Offline

Age: 44

Posts: 2

Joined: 22nd Sep 2017

Ride: Ford Falcon ef

Location: Melbourne
VIC, Australia

Yeah, sometimes on a hot day even when I haven't started it for the first time ,like about lunchtime, just turned the ignition on, the fans come on, economy light. It lets me start it but runs real crappy and blows alot of smoke and then I turn it off. In 5 minutes I restart it, beautiful. It used to do this only on really hot days like 37 c but now starting to do it more often even just warm days. Changed the oxy sensor. Do u reckon its the map sensor? I luv this car parts only $15-$30. Thanks guys. Michael,
Top
 Profile  
 
 
 Post subject: Re: Ford Falcon ef
Posted: Thu Sep 28, 2017 9:09 am 
Fordmods Junkie
Offline
User avatar

Posts: 11723

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Not sure how a MAP sensor will affect the thermos fans going on and causing economy light to come on. When you say it blows a lot of smoke, what colour is the smoke? Black/white?

Like efxr6wagon mentioned, you can try and swap out the ECU for a good one and see if that fixes the issue.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Oct 20, 2017 4:21 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names