Fordmods Logo

fuel pressure 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: fuel pressure
Posted: Wed Sep 30, 2009 11:36 am 
Getting Side Ways
Offline

Posts: 973

Joined: 15th Nov 2004

Ride: el wagon

Location: melbourne
VIC, Australia

El fairmont i6 dual fuel, GRA system

I have no fuel pressure :cry:

I have: changed fuel pump (twice)
new filter
changed fuel pressure valve
checked pump operation (you can hear it working)

But i simply don't have any pressure. I can disconnect the fuel lines anywhere w/out relieving the pressure, and it simply wont run on petrol. It runs for maybe two seconds, and then stops.

The fuel pump does what it is supposed to do, i.e.: runs for a second on initial key on, and then turns off until you try to start the car, and then runs again. When car tries to run on petrol, fuel pump runs and when it stalls, fuel pump stops.

I am all out of ideas.

Anybody got more ideas??
Top
 Profile  
 
 
 Post subject: Re: fuel pressure
Posted: Wed Sep 30, 2009 2:22 pm 
Stock as a Rock
Offline

Age: 29

Posts: 109

Joined: 1st Nov 2006

Ride: EL XR6

Probaby sounds stupid, but have you got the supply and return lines on the right way around?
Have you checked the pressure manually with a guage?

 

_________________

EL XR6 Manual
Tickford Kit, 18" ANZ's, Kings SL/SSL & Sachs.

Top
 Profile  
 
 
 Post subject: Re: fuel pressure
Posted: Thu Oct 01, 2009 11:23 am 
Getting Side Ways
Offline

Posts: 973

Joined: 15th Nov 2004

Ride: el wagon

Location: melbourne
VIC, Australia

That was one of the first things I checked!! :lol:

No, I haven't used a gauge, as I have had the line off at the pump outlet, and it flowed, but not at a great rate.

If there was pressure in the lines, I would get sprayed really badly with fuel as I disconnected them, as it runs at least at 275 kpa (30 psi), but this just doesn't happen :?

My next move is to check the pump resistance, should be greater than 10 ohms. But two pumps couldn't be faulty, could they??
Top
 Profile  
 
 
 Post subject: Re: fuel pressure
Posted: Thu Oct 01, 2009 12:54 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1634

Joined: 8th Jul 2007

Gallery: 21 images

Ride: EL F100 CAPRI XR EF

Power: 234 rwkw

Location: brighton
SA, Australia

have u checked or swapped the fuel pump relay under the coolant bottle to see if thats the problem? it may have bad contacts in it , get warm and fail.
Top
 Profile  
 
 
 Post subject: Re: fuel pressure
Posted: Thu Oct 01, 2009 1:05 pm 
Smokin em up
Offline

Posts: 266

Joined: 1st Sep 2007

Location: melbourne
VIC, Australia

Mate
Check the earth wire to the pump see if it damaged or frayed, bloww air air thru the fuel lines check if the fuel filter flows both check the wires under the water recovery bottle r not loose and contact the relays also check fuses in engine bay

gassa

 

_________________

When the clutch drops the bull s**t stops!!!!!

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 23 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 10:03 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names