Fordmods Logo

ggrrr Oil Pressure switch 

 

Page 2 of 2 [ 23 posts ] Go to page Previous  1, 2

 
Posted: Sun Dec 11, 2005 11:21 am 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000491

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

mm ok doing it on a creeper aint good and now i can understand why it took u so long...

 

_________________

RIP SCOTT

Top
 Profile  
 
 
Posted: Sun Dec 11, 2005 11:32 am 
Getting Side Ways
Offline

Age: 35

Posts: 533

Joined: 12th Jan 2005

Location: Melbourne
VIC, Australia

I have had exactally the same problem. After trying to fix it myself and it being a apin in the a***, I sent it to my locla mechanic.

30 mins later he called said it was fixed. $50 including a complete degrease of the engine. Not bad me thinks.
Top
 Profile  
 
 
Posted: Sun Dec 11, 2005 11:36 am 
Getting Side Ways
Offline

Age: 40

Posts: 2015

Joined: 9th Mar 2005

Gallery: 4 images

Ride: Territory TX AWD & AUII XLS EGAS

Location: East Kurrajong
NSW, Australia

unclewoja wrote:
I have had exactally the same problem. After trying to fix it myself and it being a apin in the a***, I sent it to my locla mechanic.

30 mins later he called said it was fixed. $50 including a complete degrease of the engine. Not bad me thinks.


That's cheap ... he must have done a heap of them before.
U sure he changed it ... LOL

That's one thing I have to do now ... degreaser underbonnet ... and under-car as well.

 

_________________

04 Territory TX AWD - Winter White - optioned up
06 Falcon BFII XLS ute EGAS - Winter White - EGA-54D Version 2

Top
 Profile  
 
 
Posted: Mon Dec 12, 2005 11:34 am 
Getting Side Ways
Offline

Age: 35

Posts: 533

Joined: 12th Jan 2005

Location: Melbourne
VIC, Australia

Mechan1k wrote:
unclewoja wrote:
I have had exactally the same problem. After trying to fix it myself and it being a apin in the a***, I sent it to my locla mechanic.

30 mins later he called said it was fixed. $50 including a complete degrease of the engine. Not bad me thinks.


That's cheap ... he must have done a heap of them before.
U sure he changed it ... LOL

That's one thing I have to do now ... degreaser underbonnet ... and under-car as well.


Yep. I'm sure he changed it because I supplied the switch for him and it had a different connection on it so he had to put another connector on the wire.
Top
 Profile  
 
 
Posted: Mon Dec 12, 2005 11:55 am 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 2637

Joined: 5th Nov 2004

Ride: EL TURBO GHIA

Power: 372 rwkw

Location: penrith
NSW, Australia

dude i changed my sender in like 30 mins ,didnt even have to jack the car up ,maybe the switch's are different to the sender's ???

 

_________________

HMMMM BOOST !!!


ED fairmont R.I.P

STREET FORDS FEATURE CAR ISSUE 42

Top
 Profile  
 
 
Posted: Mon Dec 12, 2005 6:45 pm 
ACT Cruise Moderator
Offline
User avatar

Age: 36

Posts: 6275

Joined: 24th Nov 2004

Ride: '06 BF GT-P

Power: 293 rwkw

Location: Canberra
ACT, Australia

no they're they same, but easier to get to without a BBM in the way.

 

_________________

1998 DL LTD in Sparkling Burgundy, daily, 302W, stereo, slow - 97.5rwkw
2006 BF GT-P in Ego, mods. 293rwkw - 12.427@109 - 0-1000m 24.838@221

Top
 Profile  
 
 
Posted: Wed Dec 14, 2005 7:25 pm 
Getting Side Ways
Offline

Age: 40

Posts: 2015

Joined: 9th Mar 2005

Gallery: 4 images

Ride: Territory TX AWD & AUII XLS EGAS

Location: East Kurrajong
NSW, Australia

Yeah ... the manifold is different. There was more room around the XG manifold (I am pretty sure the XG has the ED motor)

I know ... I used to have an XG and remember the intake manifold on that.

Oh ... that reminds me ... I saw my old ute the other day in Leumeah when doing delivery work ... still has the same plates ... same condition as well ... nice to see.

 

_________________

04 Territory TX AWD - Winter White - optioned up
06 Falcon BFII XLS ute EGAS - Winter White - EGA-54D Version 2

Top
 Profile  
 
 
Posted: Thu Dec 15, 2005 5:46 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 695

Joined: 5th Nov 2004

Gallery: 7 images

Ride: 2008 WQ Fiesta XR4

Location: Adelaide.
SA, Australia

You should try to change the V8 sender. A craptacular experience...

 

_________________

2008 WQ Fiesta XR4
2007 LS Focus CL

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 23 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 2:15 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names