Fordmods Logo

Help needed please!!! Ticking from EF auto 


Page 1 of 1 [ 1 post ] 

 Post subject: Help needed please!!! Ticking from EF auto
Posted: Sun Apr 12, 2009 11:15 am 
Parts Gopher
User avatar

Posts: 53

Joined: 4th Mar 2007

Location: Melbourne
VIC, Australia

Hey boys, I need help on the one please.

I've got a EF wagon, auto, dual fuel but runs only LPG and I've got this ticking coming from the trans.

Now, before we go any further, its not the lifters, its not the exhaust or any other simple explanation.

It comes from the transmission, only when its in drive ( not 1st,2nd or 3rd) and ONLY when under acceleration. Its a constant ticking that seems to be coming out of the passengers side and it remains at a constant speed regardless of the speed of the car. I have had the inspection panel off and checked the convertor bolts, which were all fine.

It has been happening since I bought the car and I have added a trans cooler and serviced the trans as well. It doesn't affect the performance at all but seems to be getting slowly louder.

It has never run on petrol and I have since removed the petroltank to fit another LPG tank, could it be the fuel pump????

I thought I'd ask here first before taking it to a mechanic and wasting money. I'm hoping its a simple fix as opposed to a rebuild.

All suggestion welcomes and appreciated





Who cares how it looks, power is everything, looks are for metrosexuals.....

Don't only encourages them.

Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: barraea, steve wardle, Yahoo [Bot] and 27 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 22, 2016 3:09 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names