Fordmods Logo

Help think i broke the starter motor 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: Help think i broke the starter motor
Posted: Sun Jul 29, 2007 9:27 pm 
Getting Side Ways
Offline
User avatar

Age: 38

Posts: 724

Joined: 11th Nov 2005

Gallery: 1 images

Ride: BF Fairmont

Location: Melbourne
VIC, Australia

I think ive got some serious issues.... I replaced the water pump today and got the balancer back on started it 2 times with no problems now it wont start... The starter motor clicks like crazy when u try to turn it over. I think it might be buggered. If its stuffed could i have broken something else in the process?? That au conversion is seeming like a really good idea atm...............
Top
 Profile  
 
 
Posted: Sun Jul 29, 2007 9:46 pm 
Getting Side Ways
Offline

Age: 38

Posts: 1319

Joined: 5th Nov 2004

Ride: 66 Coupe

Location: Perth
WA, Australia

if its clicking like crazy, you might either have a flat battery, or a bad connection on the battery / earth etc.

Put the headlights and high beams on and try start it, do the lights stay on?
Top
 Profile  
 
 
Posted: Sun Jul 29, 2007 10:01 pm 
Smokin em up
Offline

Age: 35

Posts: 296

Joined: 16th Oct 2006

Ride: 94 EF (OPT20), TF Cortina Ghia

Location: Bendigo
VIC, Australia

^^^^ Yep that'd do it alright.

 

_________________

"Look I found tape, I'm a mechanic now!!!" Mike Teutul

Top
 Profile  
 
 
Posted: Mon Jul 30, 2007 6:26 am 
Getting Side Ways
Offline
User avatar

Age: 38

Posts: 724

Joined: 11th Nov 2005

Gallery: 1 images

Ride: BF Fairmont

Location: Melbourne
VIC, Australia

Lights dim very badly then go back to full strength. Occasionally when u try to turn it it dies in the a** like there is no power eh.... Im pretty stumped.
Top
 Profile  
 
 
Posted: Mon Jul 30, 2007 8:21 am 
Getting Side Ways
Offline

Age: 38

Posts: 1319

Joined: 5th Nov 2004

Ride: 66 Coupe

Location: Perth
WA, Australia

yep definately a flat / buggered battery or bad battery connection / cable
Top
 Profile  
 
 
Posted: Mon Jul 30, 2007 8:32 am 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 3687

Joined: 4th Mar 2005

Gallery: 23 images

Ride: XR6 Turbo

Location: Taree
NSW, Australia

ur battery is flat

 

_________________

SS Inductions CAI, K&N Filters, M-spec FMC, Turbosmart BOV, 8psi capa tune, X-force cat.

Mods going on: Nizpro springs, bosch 040 pump + Walbro gss341, 600cc injectors, PWR transcooler, 20% Underdrives, 15psi Actuator, Kingspring SSL's, 15psi tune.....More coming

Top
 Profile  
 
 
Posted: Tue Jul 31, 2007 5:05 pm 
Parts Gopher
Offline

Posts: 50

Joined: 2nd Apr 2007

Location: sydney
NSW, Australia

Bad connection on the battery terminals or the battery itself has s**t itself..
Top
 Profile  
 
 
Posted: Tue Jul 31, 2007 7:36 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 1132

Joined: 11th Jun 2006

Gallery: 1 images

Ride: ef fairmont,

Location: brisbane
QLD, Australia

put new battery in it start it and check voltage may have knocked something on the alternator ???

 

_________________

95 ef montfor sale pm for info, 88 hilux mud truck

Top
 Profile  
 
 
Posted: Wed Aug 01, 2007 3:25 pm 
Getting Side Ways
Offline

Posts: 404

Joined: 8th Jun 2006

Location: melbourne
VIC, Australia

The clicking noise will be the relay, either it is not getting enough power (flat battery/poor connections), or the relay is faulty. After charging/checking battery and cleaning terminal connections, try swapping the starter relay for the low beam relay.
Top
 Profile  
 
 
Posted: Sat Aug 04, 2007 2:25 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 1132

Joined: 11th Jun 2006

Gallery: 1 images

Ride: ef fairmont,

Location: brisbane
QLD, Australia

starter relay or starter soliniod is whats clicking

 

_________________

95 ef montfor sale pm for info, 88 hilux mud truck

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: No registered users and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 1:53 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names