Fordmods Logo

Help with some massive pinging problem under load on EL XR6 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: Help with some massive pinging problem under load on EL XR6
Posted: Sat Jan 16, 2016 1:14 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 545

Joined: 3rd Oct 2006

Ride: EL XR-6

Location: Geelong
VIC, Australia

hey guys ive been trying to work out why my EL XR6 is pinging under load from as low as 1500rpm and also on a warm day the pinging is louder/worse. now i know pinging can damage the engine so i would like to get it sorted out before something really goes wrong with it.

This morning i pull off the rocket cover and check if i had the timing out when i install the au11 bottom end in the EL also had to replace timing cover gasket as it was leaking but what i can see the timing looks to be spot on as i took some pics to show?

ive notice the spark plugs have seen better days i have pics of those too. Ive also had the car scanned and the only error code the came up was from the power steering swtich which i dont think it has anyting to do with pinging side of things. The machanic mention that i had a noisy pcv valve which he said vaccum could be the problem i said replace that not too long ago so i went and brought a geniune pcv valve from ford but the pinging was still there. anyway the things i have replace and check.

Fuel filter
Spark Plugs leads were done too long ago as i do have my old set as a spare
harmonic balancer
PCV valve
02 sensor was replace hmm roughly 2yr ago with a VDO brand so im thinking that could be the problem?

ive problem miss something in the list but anyway
if anyone has some knowledge on pinging problems i would be very much appreciated thanks

 

 

Attachments:
20160116_162452.jpg
20160116_162452.jpg [ 58.79 KiB | Viewed 22 times ]
20160116_113534.jpg
20160116_113534.jpg [ 70.83 KiB | Viewed 18 times ]
20160116_113518.jpg
20160116_113518.jpg [ 76.32 KiB | Viewed 18 times ]
20160116_113452.jpg
20160116_113452.jpg [ 84.37 KiB | Viewed 19 times ]
20160116_113231.jpg
20160116_113231.jpg [ 62.1 KiB | Viewed 18 times ]
20160116_113223.jpg
20160116_113223.jpg [ 118.4 KiB | Viewed 16 times ]

Last edited by jamie22_cole on Sat Jan 16, 2016 5:17 pm, edited 1 time in total.

Top
 Profile  
 
 
 Post subject: Re: Help with some massive pinging problem under load on EL XR6
Posted: Sat Jan 16, 2016 4:34 pm 
Getting Side Ways
Offline
User avatar

Age: 27

Posts: 3369

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

o2 sensor won't cause pinging. if it fails it'll run rich.

Pinging is either lean fuel or timing related.

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: Help with some massive pinging problem under load on EL XR6
Posted: Sat Jan 16, 2016 5:31 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 545

Joined: 3rd Oct 2006

Ride: EL XR-6

Location: Geelong
VIC, Australia

okay thanks for the reply 89.svo
surely it wouldnt be pinging off it head when the timing is pretty much near spot on as seen in the pics?
if the fuel pump isnt up to scratch would it cause it to lean out?
or the fuel regulator not handling under load when warm?
Top
 Profile  
 
 
 Post subject: Re: Help with some massive pinging problem under load on EL XR6
Posted: Sat Jan 16, 2016 5:32 pm 
Technical Contributor
Offline

Age: 59

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Timing marks are spot on from what I see in the picks but what about the dizzy?

Have you tried resetting the timing?
Top
 Profile  
 
 
 Post subject: Re: Help with some massive pinging problem under load on EL XR6
Posted: Sat Jan 16, 2016 6:11 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 545

Joined: 3rd Oct 2006

Ride: EL XR-6

Location: Geelong
VIC, Australia

Yep done that still no luck
Top
 Profile  
 
 
 Post subject: Re: Help with some massive pinging problem under load on EL XR6
Posted: Sat Jan 16, 2016 6:58 pm 
Getting Side Ways
Offline

Age: 34

Posts: 1109

Joined: 27th Dec 2011

Gallery: 6 images

Ride: ef falcon futura

Power: 154 rwkw

Location: Koo Wee Rup
VIC, Australia

How did you set base timing?

 

_________________

ef futura, pacemakers, 2.5inch catback, k&n panel filter and 3.45 lsd. extractors/cat, ticky head, custom cam grind, t5. now onto cosmetics.

Top
 Profile  
 
 
 Post subject: Re: Help with some massive pinging problem under load on EL XR6
Posted: Sun Jan 17, 2016 7:53 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 545

Joined: 3rd Oct 2006

Ride: EL XR-6

Location: Geelong
VIC, Australia

as in bridging out the two pins in the fuse box under the dash and then wait for the engine revs to drop before adjusting the dizzy?
Top
 Profile  
 
 
 Post subject: Re: Help with some massive pinging problem under load on EL XR6
Posted: Sun Jan 17, 2016 8:46 pm 
Getting Side Ways
Offline

Age: 34

Posts: 1109

Joined: 27th Dec 2011

Gallery: 6 images

Ride: ef falcon futura

Power: 154 rwkw

Location: Koo Wee Rup
VIC, Australia

Yeah that. What did you set base to? 10deg or 0 deg?

 

_________________

ef futura, pacemakers, 2.5inch catback, k&n panel filter and 3.45 lsd. extractors/cat, ticky head, custom cam grind, t5. now onto cosmetics.

Top
 Profile  
 
 
 Post subject: Re: Help with some massive pinging problem under load on EL XR6
Posted: Tue Jan 19, 2016 8:34 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 545

Joined: 3rd Oct 2006

Ride: EL XR-6

Location: Geelong
VIC, Australia

pretty much around 0 before it nearly stalls it sits around 10degs advance
Top
 Profile  
 
 
 Post subject: Re: Help with some massive pinging problem under load on EL XR6
Posted: Tue Jan 19, 2016 11:36 pm 
Getting Side Ways
Offline

Age: 34

Posts: 1109

Joined: 27th Dec 2011

Gallery: 6 images

Ride: ef falcon futura

Power: 154 rwkw

Location: Koo Wee Rup
VIC, Australia

Base timing needs to be set at 0. If its set at 10deg then its adding an extra 10deg ontop of the spark maps

 

_________________

ef futura, pacemakers, 2.5inch catback, k&n panel filter and 3.45 lsd. extractors/cat, ticky head, custom cam grind, t5. now onto cosmetics.

Top
 Profile  
 
 
 Post subject: Re: Help with some massive pinging problem under load on EL XR6
Posted: Wed Jan 20, 2016 5:02 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 545

Joined: 3rd Oct 2006

Ride: EL XR-6

Location: Geelong
VIC, Australia

sorry i type that back to front its 10degs before its nearly stalls then its at 0
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: bdl and 32 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue May 30, 2017 12:13 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names