Fordmods Logo

HI OIL PRESSURE 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: HI OIL PRESSURE
Posted: Sat Feb 26, 2005 1:10 pm 
Parts Gopher
Offline

Age: 30

Posts: 51

Joined: 7th Dec 2004

Location: Bairnsdale
VIC, Australia

WAT DOES IT MEAN IF I HAVE REALY HI OIL PRESSURE. AFTER ABOUT TEN MINUTES IT DROPS SLIGHTLY
Top
 Profile  
 
 
 Post subject: Re: HI OIL PRESSURE
Posted: Sat Feb 26, 2005 1:24 pm 
Parts Gopher
Offline

Age: 47

Posts: 72

Joined: 8th Nov 2004

Gallery: 3 images

Ride: Fairmont

Location: Sydney
NSW, Australia

driftomatic wrote:
WAT DOES IT MEAN IF I HAVE REALY HI OIL PRESSURE. AFTER ABOUT TEN MINUTES IT DROPS SLIGHTLY


Are you referring to high oil pressure upon start-up then slightly goes down after you reach normal operating temperature?

If YES, then that would most likely be due to oil viscosity which changes as temperature ...it goes thinner as it heats up, thus giving you a lesser pressure reading.

If NO, then that's a whole new ballgame.

Cheers. :lol:
Top
 Profile  
 
 
Posted: Sat Feb 26, 2005 2:37 pm 
Parts Gopher
Offline

Age: 30

Posts: 51

Joined: 7th Dec 2004

Location: Bairnsdale
VIC, Australia

so wat happeneds if it stays high wat problems will occur and wat causes it to be high
Top
 Profile  
 
 
Posted: Sat Feb 26, 2005 5:18 pm 
Getting Side Ways
Offline

Age: 31

Posts: 3893

Joined: 15th Nov 2004

Gallery: 24 images

Ride: BF MKII V8 Fairmont Ghia

Location: Perth
WA, Australia

what car?

i believe ef or el guages were really quite dodgey?

 

_________________

2007 Steel BF Ghia MKII V8 - 19" GTP's + Superlows

Top
 Profile  
 
 
Posted: Sat Feb 26, 2005 6:11 pm 
Parts Gopher
Offline

Age: 30

Posts: 51

Joined: 7th Dec 2004

Location: Bairnsdale
VIC, Australia

my ef fairmont. i thought they were dodge
Top
 Profile  
 
 
Posted: Sun Feb 27, 2005 4:47 pm 
Fordmods Newbie
Offline

Posts: 5

Joined: 26th Feb 2005

Location: Canberra
ACT, Australia

Try replacing the oil pressure send unit - should fix the problem. If the oil pressure were actually as high as you are suggesting, your oil pump would probably have failed by now.
Top
 Profile  
 
 
Posted: Tue Mar 01, 2005 10:04 pm 
Fordmods Newbie
Offline

Posts: 1

Joined: 1st Mar 2005

Ride: EF

Location: Gladstone
QLD, Australia

Have you checked the amount of oil in your sump? Make sure it hasnt been overfilled which could lead to blown gaskets down the track. Too much oil could be the problem for high oil pressure.
Top
 Profile  
 
 
Posted: Tue Mar 01, 2005 10:51 pm 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 2705

Joined: 6th Nov 2004

Gallery: 11 images

Ride: 2009 FG XR6 Sedan

Location: Melbourne
VIC, Australia

Make sure the terminal on the pressure sender is clean and the plug is in good condition.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 34 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 9:24 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names