Fordmods Logo

Idle issues in EL Falcon 

 

Page 1 of 2 [ 16 posts ] Go to page 1, 2  Next

 
 Post subject: Idle issues in EL Falcon
Posted: Tue Apr 02, 2013 9:11 am 
Fordmods Newbie
Offline

Age: 24

Posts: 8

Joined: 26th Mar 2013

Ride: 98 El Falcon Futura

Location: Ringwood
VIC, Australia

Hi all,

I've looked through the forums but havn't found one matching my issue properly, so here is my problem.
I recently took the battery out of my EL Falcon auto to get my partners car going, since then it's had issues with idle.
Each time I'm slowing down for a red light or something, the revs drop to 300-400 then wobble up and down between 300 and 1000 until I'm stopped. It's stalled 3 or 4 times.
Also, I have to reverse my car and 'wiggle' to turn my car around in the driveway to get out, and when switching between drive and reverse the revs will often drop and the car will shake, like it does when slowing.
I've tried following some throttle/ecu reset steps, and just changed the spark plugs.
It never happened before the battery was out.\

Also, I noticed the lights dim when the idle drops.

I'm not too handy with cars, and this problem is s^%tting my up the wall, as I've only bought the car a month ago to replace another car with a stalling issue hahahaha

Any help will be appreciated, cheers
-Ben
Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Tue Apr 02, 2013 9:43 am 
Getting Side Ways
Offline
User avatar

Posts: 1427

Joined: 21st May 2005

Location: Melbourne
VIC, Australia

Most likely its the ISC (Idle Speed Controller) causing your problems.

 

_________________

EL Fairmont Ghia - Manual - Supercharged
- The Car
- The Headlights

Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Tue Apr 02, 2013 10:19 am 
Fordmods Newbie
Offline

Age: 24

Posts: 8

Joined: 26th Mar 2013

Ride: 98 El Falcon Futura

Location: Ringwood
VIC, Australia

Hi,

Cheers for the reply

Would that be caused by the battery being out for 20 mins or so?
Also, what can I do about it?
Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Tue Apr 02, 2013 10:21 am 
Fordmods Newbie
Offline

Age: 24

Posts: 8

Joined: 26th Mar 2013

Ride: 98 El Falcon Futura

Location: Ringwood
VIC, Australia

Forgot to mention, it seems to hold revs a little better when it's cold, the issue happens more as the engine gets up to temp
Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Tue Apr 02, 2013 10:32 am 
Fordmods Junkie
Offline
User avatar

Posts: 11687

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

It is normal for the engine to hold the revs when cold. The ECU runs a richer fuel mapping and slightly higher idle when cold. Once at operating temperatures it will revert back to standard fuel mapping/idle.

From my experience with my EL (with mods), I get the same issue, but that could be due to my mods. It takes about 200km of all driving conditions for the car to idle properly. Not sure if it's because the ECU is relearning the idle (even though it shouldn't need to) or something else.

Give the ISC/throttle body a clean and see how you go.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Tue Apr 02, 2013 10:37 am 
Fordmods Newbie
Offline

Age: 24

Posts: 8

Joined: 26th Mar 2013

Ride: 98 El Falcon Futura

Location: Ringwood
VIC, Australia

Righto, I'll give that ago.
Cheers :)
Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Tue Apr 02, 2013 2:20 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 8

Joined: 26th Mar 2013

Ride: 98 El Falcon Futura

Location: Ringwood
VIC, Australia

Not sure if it's too relevant, but I figure it can't hurt to mention.
If the car's just idling, turning the steering wheel will also hurt the revs. They'll drop then build back up.
Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Tue Apr 02, 2013 5:08 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11687

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

benmacd wrote:
Not sure if it's too relevant, but I figure it can't hurt to mention.
If the car's just idling, turning the steering wheel will also hurt the revs. They'll drop then build back up.


That's normal. When you turn the wheel you put a load on the engine dropping the idle. The power steering switch then tells the ECU to bump up idle to compensate for the load.

When the ECU in my car is reset (car battery out for about 30+ mins) and I go for a drive the first time after reset, the engine stalls when I turn the wheel (operating temp...it is fine when cold). That isn't normal...although then again I am not sure what is normal with this car anymore.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Wed Apr 03, 2013 9:28 am 
Fordmods Newbie
Offline

Age: 24

Posts: 8

Joined: 26th Mar 2013

Ride: 98 El Falcon Futura

Location: Ringwood
VIC, Australia

Ah ok cool
Driving it around thismorning to work it seemed to be ok, almost cut out once when doing a very slow tight turn, the revs kept faultering around 200 or so and the battery light on the dash would come on each time it got low, but apart from that it ran allright.
That's another thing actually, when it does stall out, the little battery light comes on on the dash.
Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Wed Apr 03, 2013 9:40 am 
Getting Side Ways
Offline
User avatar

Posts: 1427

Joined: 21st May 2005

Location: Melbourne
VIC, Australia

The battery light is normal. It's a warning that the alternator is not charging.
When it stumbles down to 200rpm, the alternator is not spinning quick enough to charge properly.
That's the same reason why your lights dim when it does this too.

 

_________________

EL Fairmont Ghia - Manual - Supercharged
- The Car
- The Headlights

Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Wed Apr 03, 2013 4:27 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 8

Joined: 26th Mar 2013

Ride: 98 El Falcon Futura

Location: Ringwood
VIC, Australia

Ahh that makes sense, cheers MAD
Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Wed Apr 03, 2013 6:11 pm 
Technical Contributor
Offline
User avatar

Age: 27

Posts: 3704

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

The base idle should be set so that even with the ISC disconnected the car should not be physically able to idle below about 600rpm... Mine wont... I have a mixed bag which is run by an EL XR6 computer...

To be doing that if the base idle is set right, it must be a severely wrong mixture or something... I'd run a self test (a how is under resources above then click tech docs)... See if any sensors are out of range like the hego or MAP...

If that passes then I'd check the fuel rail pressure and see if your fuel reg isn't stuck open or closed causing an incorrect fuel pressure in the rail... Does it blow any smoke or do anything weird?

Just 2-300 revs is way to low for what the throttle system can allow... It's like something else is fairly wrong and eventually the ECU learns how to compensate for it by change injector duty cycle or duration or spark mapping or something... Lucky the ECU's in these cars are clever enough to learn how to adapt well enough to ever run ok...

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Thu Apr 04, 2013 9:06 am 
Fordmods Newbie
Offline

Age: 24

Posts: 8

Joined: 26th Mar 2013

Ride: 98 El Falcon Futura

Location: Ringwood
VIC, Australia

Hey Timmy,

I'll try run a self test tonight and post how it goes once I do

Nah, never any smoke or anything, runs beautifully once going, only stumbles on idle, also slowing down to a stop, or reversing from a stop. If it goes low enough to hit 200-300 revs, it'll usually bounce back up before dropping to around 500 again, then repeat.
It's running a little better day by day, but only a little bit.

I should've never taken out the battery haha
Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Mon Mar 14, 2016 2:33 pm 
Fordmods Newbie
Offline

Age: 38

Posts: 10

Joined: 1st Jul 2010

Ride: Falcon 97 EL wagon

Location: Melbourne
VIC, Australia

I have an EL Falcon too (automatic) and have the exact same problem...I took it for a drive after reconnecting the battery and now I have the exact same idle issue that you've been discussing here. It was running fine (and always has done) until I took out the battery to replace the headlight.

It now conks out every time I slow down for a red light, corner, give way sign etc (the revs drop and the car wobbles up and down until it completely conks out).

This has only started happening since I took the battery out. Even when parked/stationary - the car starts fine and idles but it stalls as soon as I put it into park.

Did you solve the issue by any chance?
Was it the idle speed controller?
If so can anyone point me to a 'how to' guide to fix the issue?

I'm pretty useless with cars (can only really do the basics - change the globes, brake pads, replace side mirrors, taillight housing etc with aftermarket parts etc)...but a 'how to' on this would be great if there is one! Googling brought me here...not found much else...any help would be massively appreciated
Top
 Profile  
 
 
 Post subject: Re: Idle issues in EL Falcon
Posted: Tue Mar 22, 2016 6:59 pm 
Stock as a Rock
Offline

Age: 63

Posts: 129

Joined: 4th Feb 2016

Location: australia
VIC, Australia

The reason the engine is stalling is because when you disconnected the battery the ecu lost it's scratch pad memory RAM, and now it is using ROM. Over a period of time the ecu will make small changes to the injectors from information from the O2 sensor and the idle speed control motor. When the base idle is set at the factory there will be a small amount of air bypassing the throttle plate, over a period of time build up accumulates behind the throttle plate blocking the bypass air, so the idle speed control motor opens more to control the idle, higher duty cycle from the ecu.When the battery is disconnected the ecu will loose it's memory on how much air it was bypassing. Remove the air pipe to the throttle plate, get a tin of carbi cleaner and open the throttle plate and clean the throttle plate inside and the inner housing. This should fix your problem, if not you will have to do an idle relearn. When you turn the key to the start position the idle speed control motor will receive a full earth from the ecu via pin 21, and when the engine starts it will duty cycle the ground to provide a stable idle speed depending on coolant temp from pin 7. It is a simple problem to fix.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 16 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Jul 23, 2017 7:54 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names