Fordmods Logo

Injectors 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: Injectors
Posted: Thu Aug 07, 2008 3:58 pm 
Parts Gopher
Offline

Posts: 50

Joined: 18th Jan 2005

Location: South West
WA, Australia

Hi, Can EF injectors run in an AU engine, without any bad effects, like burning a hole in the pistons or anything bad like that? My AU engine into EF conversion is chewing the fuel with the AU injectors. I know the EF ones will fit, just not sure if it will cause problems, due to different spray pattern or head design.
Thanks,
Jas.
Top
 Profile  
 
 
Posted: Thu Aug 07, 2008 4:31 pm 
Oompa Loompa
Offline

Age: 33

Posts: 33

Joined: 30th Jul 2008

Location: Liverpool
NSW, Australia

its an au engine to start off with so why would au injectors be a problem? au injectors are also interchangable into eseries engines with no problems, i suggest you look elsewhere for your overfuelling problem... check your sensors too

 

_________________

CMS stage 3 cam, CMS stage 2 head, intake, extractors, exhaust...
standard bottom end, standard ECU
14.3 @ 96mph

Top
 Profile  
 
 
Posted: Thu Aug 07, 2008 5:30 pm 
Parts Gopher
Offline

Posts: 50

Joined: 18th Jan 2005

Location: South West
WA, Australia

I mean EF injectors into an AU motor.
Top
 Profile  
 
 
Posted: Thu Aug 07, 2008 5:37 pm 
Oompa Loompa
Offline

Age: 33

Posts: 33

Joined: 30th Jul 2008

Location: Liverpool
NSW, Australia

they are rated very similar, injectors are not your problem...

 

_________________

CMS stage 3 cam, CMS stage 2 head, intake, extractors, exhaust...
standard bottom end, standard ECU
14.3 @ 96mph

Top
 Profile  
 
 
Posted: Thu Aug 07, 2008 6:19 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

As FAST-XR said...there might be other problems causing your fuel consumption.

The AU injectors shouldn't affect consumption as such, since your ECU will do some changes to compensate.

Check your O2 sensor, any vacuum leaks or maybe fuel leak somewhere.

phong =P~

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
Posted: Thu Aug 07, 2008 10:27 pm 
Parts Gopher
Offline

Posts: 50

Joined: 18th Jan 2005

Location: South West
WA, Australia

Its also still pinging. I think it must be the knock sensor.
I tried the oxygen sensor, wont know how the fuel consumption is until tomorrow, but its pinging after I put that in.
The knock sensor rattles and spins a bit between the plastic and the metal base, none of the others I've looked at move at all. Anyone know what they might be worth? Secondhand?
Top
 Profile  
 
 
 Post subject: Re: Injectors
Posted: Thu Aug 07, 2008 11:04 pm 
Getting Side Ways
Offline

Age: 33

Posts: 6746

Joined: 13th Mar 2006

Gallery: 10 images

Ride: NCII Fairlane

Location: Bathurst
NSW, Australia

magnum012 wrote:
Hi, Can EF injectors run in an AU engine, without any bad effects, like burning a hole in the pistons or anything bad like that? My AU engine into EF conversion is chewing the fuel with the AU injectors. I know the EF ones will fit, just not sure if it will cause problems, due to different spray pattern or head design.
Thanks,
Jas.


EA > EL injectors are 18lbs (if i can recall) AU are 20lbs

with chewing the fuel check any sensor for anything abnormal or even unplugged.. pinging check spark plugs or leads timing etc, or just get some higher octane fuel,, or chuck some octane boost in.

 

_________________

R.I.P Tobias my son.

Top
 Profile  
 
 
Posted: Fri Aug 08, 2008 1:19 am 
Parts Gopher
Offline

Posts: 50

Joined: 18th Jan 2005

Location: South West
WA, Australia

I had another thread going about the pinging but this one is up the top of the stack now so ill go here.
I have changed the plugs to a colder range, you really need to belt it for it to ping but it does. Its a standard motor so it shouldn't be pinging. I have tried a good oxy sensor tonight but still pings.
I would have swapped the knock sensor from my el into it but its a b**ch to get to so it will be a weekend job. Thanks for all the advice guys.
Top
 Profile  
 
 
Posted: Fri Aug 08, 2008 12:58 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 10826

Joined: 17th Apr 2005

Gallery: 34 images

Ride: BF MK11 XR 6 TURBO ZF 6spd

Power: 225 rwkw

Location: glenwood/sydney
NSW, Australia

check the fuel pressure regulator... (bolted to the firewall end of the fuel rail) it might be bung resulting in over "fueling" and excessive fuel consumption... failing that... check the ECU too... they can partialy fail too with consumption "going through the roof".....

 

_________________

Todd: Nurse, suction.
Nurse: The patient's not even here yet.
Todd: I know.

http://www.youtube.com/watch?v=_GQpRYRcAiA

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 35 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 4:01 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names