Fordmods Logo

Issues 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: Issues
Posted: Thu Mar 10, 2005 3:36 pm 
Fordmods Newbie
Offline

Age: 31

Posts: 4

Joined: 10th Nov 2004

Ride: EA S MPFI

Location: Coffs Harbour
NSW, Australia

Hey peepz, I got a EA S and everytime I brake the the dash power goes off, and when I put my blinker on the dash power goes on and off on and off with the clicker.. I dont know if its earthing problems or a fuse...

any suggestions?

 

_________________

Falcon PowaHh!

Top
 Profile  
 
 
Posted: Thu Mar 10, 2005 3:52 pm 
Technical Contributor
Offline
User avatar

Posts: 2799

Joined: 6th Nov 2004

Gallery: 7 images

Ride: Falcon

Location: Sydney
NSW, Australia

sounds like a earthing issues... actually a short circuit somewhere more likely. Take the instrument cluster out, and check all the wires, make sure that they aren't touching anywhere. I don't see it been a fuse


the other possibility is that your battery is almost dead, and indicating and brake lights take up quite some power. So check your battery connections.

I suggest do that first, check your battery, check the voltage accross thge terminals, clean the terminals. See how you go after that.

Cheers

 

_________________

;++JustForDimSim++;

Cheap, fast and reliable.. choose 2.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 25 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 4:11 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names