Fordmods Logo

Issues with thermo fan... 

 

Page 2 of 2 [ 18 posts ] Go to page Previous  1, 2

 
 Post subject: Re: Issues with thermo fan...
Posted: Wed Jul 25, 2012 9:30 pm 
Smokin em up
Offline
User avatar

Posts: 218

Joined: 28th Apr 2012

Ride: EL Wagon, DF LTD

Location: Vermont South
VIC, Australia

Righto so after the temperature gauge went all the way up today and the light went on, I decided to get around to fixing that fan. Turns out it was the first relay, switched that over and robert's your father's brother, temperature went straight down with both fans working. I think the problem was that because it was the passenger side fan that was busted, and thats the side where the hot coolant goes into the radiator, it wasn't being cooled properly. So if I had to have a broken fan it would've been better to be the right one... But all fixed now.

On a side note to the boiling coolant though, I am thinking it may be just the heat soak thing, but might get around to replacing the radiator cap because I'm not sure if its ever been replaced. Also it turns out that the mechanic just topped the coolant up, but didn't flush it. He didn't pull a dodgy, just a communication error. So I'll be probably doing that this weekend as again, I'm not sure of the last time it was done, and then I'll see if it improves.

 

_________________

The gene pool could do with a little bit of chlorine...

Top
 Profile  
 
 
 Post subject: Re: Issues with thermo fan...
Posted: Sat Jan 15, 2022 6:16 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 7

Joined: 23rd Aug 2021

Ride: 1997 Ford Falcon XR6

Location: Melbourne
VIC, Australia

Hey mate did you end up fixing this issue, I’ve got the passenger thermo fan code too. My AC also isn’t turning on so I think it may be thermo related as I’ve tested every possible part of the ac circuit.
Top
 Profile  
 
 
 Post subject: Re: Issues with thermo fan...
Posted: Mon Jan 17, 2022 10:28 pm 
Parts Gopher
Offline

Age: 45

Posts: 85

Joined: 31st Oct 2016

Ride: AUII Fairmont- Tickford enhanced

Location: Freezer
TAS, Australia

Start a new thread if you have questions.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 18 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: Google [Bot] and 46 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Sep 27, 2022 3:07 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names