Fordmods Logo

kinda worried here 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: kinda worried here
Posted: Sun Dec 11, 2005 1:28 am 
Parts Gopher
Offline
User avatar

Age: 30

Posts: 68

Joined: 11th Feb 2005

Location: St Leonards
NSW, Australia

hey coming home 2nite everythin was fine until i went to take the last turn and it sounded as if the tyre was rubbing against the car and i could feel it in the steering as well, but then i let the car sit there and i could even hear it just in the engine bay as well. the car started rattling a bit sounded really bad like it wasnt warm enough and was idling wrong but at the same time makin this weird a** sound..
really worried just need some help, hopefully everything will be fine in the morning but i wanna know what the hell is going on!!
i driving normally not even accelerating fast or going into the corners fast, i was driving slow if anything! and sorry by the way its an EB sedan

cheers

 

_________________

at the bottom of the chain

Top
 Profile  
 
 
Posted: Sun Dec 11, 2005 1:55 am 
Getting Side Ways
Offline

Age: 36

Posts: 2215

Joined: 5th Nov 2004

Gallery: 17 images

Ride: Oettinger Golf GTI

Location: Sydney
NSW, Australia

was it chugging along? fowl plug, bad lead maybe? maybe somethings loose or come off as u did the corner.. check the obvious things first.. stupid things like that have happened to me lol
Top
 Profile  
 
 
Posted: Sun Dec 11, 2005 10:55 am 
Parts Gopher
Offline
User avatar

Age: 30

Posts: 68

Joined: 11th Feb 2005

Location: St Leonards
NSW, Australia

nah it wasnt chugging along, i'll check for things that have come off.. two things i forgot to mention tho was that i put in new slotted rotors about 3 weeks ago but the guy who put them in seem a little bit dodgy and the other thing was when i got out of the car it wreaked of burning rubber or it couldve been the smell that comes off your brakes when you've been braking heavily which i mentioned i definately wasnt doing!

 

_________________

at the bottom of the chain

Top
 Profile  
 
 
Posted: Sun Dec 11, 2005 11:18 am 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 2705

Joined: 6th Nov 2004

Gallery: 11 images

Ride: 2009 FG XR6 Sedan

Location: Melbourne
VIC, Australia

Hope he put the split pin back in on the stub. Also did he use high temp grease?
Top
 Profile  
 
 
Posted: Sun Dec 11, 2005 11:42 am 
Parts Gopher
Offline
User avatar

Age: 30

Posts: 68

Joined: 11th Feb 2005

Location: St Leonards
NSW, Australia

damn i didnt check what grease he used! but also as i said even when the car was parked and still running it was mucking up

 

_________________

at the bottom of the chain

Top
 Profile  
 
 
Posted: Sun Dec 11, 2005 11:42 am 
Getting Side Ways
Offline

Posts: 988

Joined: 4th Dec 2004

Ride: el faimont, dual fuel

Location: melbourne
VIC, Australia

check behind your disks he may have put in too much grease and its come on to the disk, burning smell.
noises, check all fluids, power steering may have s**t it self.
lift up the car and spin each wheel, he may have tightened the front too much and bearing has carked it.

 

_________________

why do u write in here.

Top
 Profile  
 
 
Posted: Sun Dec 11, 2005 2:41 pm 
Parts Gopher
Offline
User avatar

Age: 30

Posts: 68

Joined: 11th Feb 2005

Location: St Leonards
NSW, Australia

ahh crap it is the power steering.. i have a leak but its at the sensor, where the wiring connects to whatever part the fluid runs through!! its just dripping straight out! should the fluid even be in the wiring??

 

_________________

at the bottom of the chain

Top
 Profile  
 
 
Posted: Sun Dec 11, 2005 4:26 pm 
Parts Gopher
Offline
User avatar

Age: 30

Posts: 68

Joined: 11th Feb 2005

Location: St Leonards
NSW, Australia

yea it was the pressure switch.. damn there goes a another $50

 

_________________

at the bottom of the chain

Top
 Profile  
 
 
Posted: Sun Dec 11, 2005 4:59 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 5924

Joined: 5th Nov 2004

Gallery: 7 images

Ride: Ford FPV FG F6 310

Power: 149 rwkw

Location: Brisbane
QLD, Australia

lucky that's all it was, a rack or a pump would have set you back alot more.

 

_________________

NEW RIDE - FPV FG F6 6spd Auto. 12.26@114MPH, 1.88 60FT on Cheapy Tyres with 38PSI - Stock except K&N filter!

R.I.P. BF XR6 Turbo - You will not be forgotten :( 12.06@120MPH

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 23 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 10:33 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names