Fordmods Logo

leaky p/steer sender 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: leaky p/steer sender
Posted: Wed Feb 20, 2008 11:58 am 
Tyre Shredder
Offline

Posts: 304

Joined: 5th Sep 2006

Location: christchurch
New Zealand

On my EBII there's a small round sender sticking out of my steering rack with a wire coming out of it.

This leaked fluid once before and I had it replaced and now it's leaking again. Does anyone have a better solution for this?

 

_________________

http://www.retrotech.co.nz

Top
 Profile  
 
 
Posted: Wed Feb 20, 2008 12:28 pm 
Stock as a Rock
Offline

Age: 61

Posts: 156

Joined: 2nd Nov 2005

Ride: EA Fairmont

Location: Canberra
ACT, Australia

Hi There

Was your replacement second hand ??
If so, a brand newy may solve the problem for years.
Are you sure the plug itself is leaking and not just the thread ??
Removing, cleaning and appropriate thread sealant may
solve the problem.

I have heard of people removing them and just putting
an appropriate 'blanking' plug / bolt in them.

Not sure whether you have to short / jump the connector or not.

" Maybe " as a test ( before going the blanking plug route )
just disconnect the connector and see how the car runs, drives,
especially when turning corners or on slow full lock ( parking etc ).

Before doing the test, perhaps get confirmation that no damage to
the ECU can result, if in fact, the connector needs jumping
or something. ( yes I can be paranoid sometimes lol )
Top
 Profile  
 
 
Posted: Thu Feb 21, 2008 4:11 pm 
Stock as a Rock
Offline

Age: 33

Posts: 140

Joined: 21st Feb 2007

Gallery: 9 images

Ride: EF Citric Acid

Location: Newcastle
NSW, Australia

i changed mine yesterday cost me $60, but all you need is a bent spanner and you can do it yourself, i got a brand new part, cost me $50. to easy

Acidic

 

_________________

96 R33 Skyline

Top
 Profile  
 
 
Posted: Tue Feb 26, 2008 7:13 am 
Tyre Shredder
Offline

Posts: 304

Joined: 5th Sep 2006

Location: christchurch
New Zealand

yeah apparently it's a sender to lift the rev's on hard lock.. I've replaced the sender unit. If it leaks again then I think I'll blank it off.

was a new one last time as well.. but maybe it got knocked down there when I was doing paddock donuts. :wink:

 

_________________

http://www.retrotech.co.nz

Top
 Profile  
 
 
Posted: Tue Feb 26, 2008 8:44 am 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000491

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

JT wrote:
yeah apparently it's a sender to lift the rev's on hard lock.. I've replaced the sender unit. If it leaks again then I think I'll blank it off.

was a new one last time as well.. but maybe it got knocked down there when I was doing paddock donuts. :wink:


actually it is used for when the car is at idle to sense when the steering rack is being turned to lift the revs slightly
im not 100% but it may be used for the speed sensitive steering some models have
i would not reccomend a blanking plug

a bet u the sender/thread is fine just make sure u replace the O ring inside!

 

_________________

RIP SCOTT

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 11:36 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names