Fordmods Logo

My CAM 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: My CAM
Posted: Mon Jan 03, 2005 7:00 pm 
Oompa Loompa
Offline

Age: 29

Posts: 47

Joined: 7th Dec 2004

Ride: XE

Location: Canberra
ACT, Australia

just wondering if putting a stage 3 wade cam on my 250 Xflow injected motor with extractors an exhaust would f**k anything up?

cheers

 

_________________

Aint
....no
...chistmas....
hammmmmmmmmmm in here.

Top
 Profile  
 
 
Posted: Mon Jan 03, 2005 7:07 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 2280

Joined: 5th Nov 2004

Ride: EF Falcon 95

Location: Rosebud
VIC, Australia

theirs a forum for X series cars, but i would assume if its installed right then it should f**k anything up so to speak. (except maybe your fuel bill)

 

_________________

Cougar Zero makes my pants fit nice.

Top
 Profile  
 
 
Posted: Mon Jan 03, 2005 7:12 pm 
Oompa Loompa
Offline

Age: 29

Posts: 47

Joined: 7th Dec 2004

Ride: XE

Location: Canberra
ACT, Australia

yeh thats what i heard, that i would start chewin the juice, but aslong as u guys dont seem to think that it would mess with too many things thats alright...also do i need to disconnect battery befor installing an avoid high RPM for a certain amount of K's?

 

_________________

Aint
....no
...chistmas....
hammmmmmmmmmm in here.

Top
 Profile  
 
 
Posted: Tue Jan 04, 2005 8:17 pm 
Smokin em up
Offline

Posts: 227

Joined: 11th Dec 2004

Location: Gold Coast
QLD, Australia

I'm not too sure how well the hamster running inside a wheel excuse for an ecu will handle the cam. The efi setup on the X-flow is very primative. Although it is just an ecu swap away to something better, I reckon even the EMS 4424 stinger is better than std and that thing is very basic.
Top
 Profile  
 
 
Posted: Tue Jan 04, 2005 9:06 pm 
Oompa Loompa
Offline

Age: 29

Posts: 47

Joined: 7th Dec 2004

Ride: XE

Location: Canberra
ACT, Australia

hamster runnin in wheel? have u seen it? don know what ur on about but does ur reply mean that is should be ok?

 

_________________

Aint
....no
...chistmas....
hammmmmmmmmmm in here.

Top
 Profile  
 
 
Posted: Tue Jan 04, 2005 9:37 pm 
Smokin em up
Offline

Posts: 227

Joined: 11th Dec 2004

Location: Gold Coast
QLD, Australia

What I am inferring is that the factory setup is pathetic. Most of them did not run closed loop (have oxy sensors), have a s**t flap door type AFM which damaged easily with backfires and ran s**t with leaky rear main seals. And to top it off the fuel economy was s**t house compared to the carby model.

But the manifold is not a bad design and all the hardware is there making it a good candidate for an ecu upgrade.
Top
 Profile  
 
 
Posted: Tue Jan 04, 2005 10:15 pm 
Getting Side Ways
Offline

Age: 36

Posts: 7287

Joined: 5th Nov 2004

Gallery: 12 images

Ride: 1994 ED XR8 Sprint

Location: Somewhere in
QLD, Australia

if you're running the bosch EFI system in your XE, you *may* be fine.....

if you've transplanted an EECIV setup from an XF......... well...... the ECU wont handle it too well, if at all

 

_________________

Banned

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 6:30 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names