Fordmods Logo

New water pump problem 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: New water pump problem
Posted: Tue Mar 04, 2014 9:36 pm 
Fordmods Newbie
Offline

Age: 23

Posts: 16

Joined: 3rd Feb 2013

Ride: Ford Falcon XH XR6 Ute

Location: Armidale
NSW, Australia

Hey guys, recently put in a new water pump to my xh xr6 falcon and it's somehow leaking underneath. Would it need new gaskets or would it be something different. I fitted a new o-ring and new gaskets but need to be certain. Cheers
Top
 Profile  
 
 
 Post subject: Re: New water pump problem
Posted: Tue Mar 04, 2014 10:52 pm 
Technical Contributor
Offline
User avatar

Age: 28

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

They come with one paper gasket installed between the body and the steel plate and then one gasket to go between the steel plate and block...

Did you soak the gaskets in water before installation and use a scraper to remove old gasket from the block before install?

Have seen brand new ones faulty but and leak out the hole in the bottom of the pump where the internal shaft seals haven't worked for whatever reason...

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: New water pump problem
Posted: Wed Mar 05, 2014 11:04 am 
Fordmods Newbie
Offline

Age: 23

Posts: 16

Joined: 3rd Feb 2013

Ride: Ford Falcon XH XR6 Ute

Location: Armidale
NSW, Australia

I used gasket sealant instead on it, I did scrape off the old gasket materiel with a proper gasket scraper
Top
 Profile  
 
 
 Post subject: Re: New water pump problem
Posted: Wed Mar 05, 2014 3:23 pm 
Fordmods Junkie
Offline
User avatar

Posts: 2757

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

TimmyA wrote:
Did you soak the gaskets in water before installation and use a scraper to remove old gasket from the block before install?

Cheers,
Tim



any reason for that?? .... have made gaskets from kornflake packets with no problems :roll: :mrgreen:
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 2:35 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names