Fordmods Logo

oil filter 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: oil filter
Posted: Sat Nov 13, 2010 9:52 pm 
Stock as a Rock
Offline

Age: 107

Posts: 164

Joined: 25th Jan 2010

Ride: 1999 au series 1

Location: sydney
NSW, Australia

can someone tell me if i can take off my oil filter without draining the sump
i need to know pretty much immediately please!
i dont want oil all over the place.
pete.
Top
 Profile  
 
 
 Post subject: Re: oil filter
Posted: Sat Nov 13, 2010 9:57 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

i'm guessing on an au 6? it'll just drain what is in the filter. like .5 of a litre

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: oil filter
Posted: Sat Nov 13, 2010 10:03 pm 
Stock as a Rock
Offline

Age: 107

Posts: 164

Joined: 25th Jan 2010

Ride: 1999 au series 1

Location: sydney
NSW, Australia

ah thanks bud!
i changed the oil today and put a k&n $20 oil filter on and now there is weird noises coming from everywere!
even a sucking air leaking sound coming from near the oil filter !
doesn't sound good.
so i thought i would get under it know and put the ryco z9 i have in the garage on
and see if it makes a difference.
Top
 Profile  
 
 
 Post subject: Re: oil filter
Posted: Sat Nov 13, 2010 10:52 pm 
Parts Gopher
Offline

Age: 36

Posts: 78

Joined: 15th Jun 2010

Ride: XD Fairmont Ghia 351

Location: Blue Mountains
NSW, Australia

The oil filter isn't double sealed is it??
( the old seal stayed stuck to the block & new seal is on the filter??? ) :?:
Top
 Profile  
 
 
 Post subject: Re: oil filter
Posted: Sun Nov 14, 2010 12:07 am 
Stock as a Rock
Offline

Age: 107

Posts: 164

Joined: 25th Jan 2010

Ride: 1999 au series 1

Location: sydney
NSW, Australia

no the seals are all good!
i just got under and took off the k&n filter and seal
then re attached my ryco z9 filter but the annoying new noises are still there.
i will have to refill the car with the same 10w30 type oil the car had in it tommorrow and see if everything goes back the way it was. ;eg no noises.
fingers crossed.
Top
 Profile  
 
 
 Post subject: Re: oil filter
Posted: Sun Nov 14, 2010 12:23 am 
Getting Side Ways
Offline

Posts: 2091

Joined: 3rd Apr 2008

Ride: EF Fairmont, XG Ute

If theres "sucking" noises coming from the area, the filter definitely isn't sealing. The funny noises will be the motor struggling with a lack of oil pressure.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 26 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 11, 2017 1:41 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names