Fordmods Logo

oil pressure light? 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: oil pressure light?
Posted: Mon May 26, 2008 7:31 pm 
Fordmods Newbie
Offline

Age: 45

Posts: 18

Joined: 25th Nov 2006

Gallery: 1 images

Location: Melbourne
VIC, Australia

hi,i need help i was stopping at the trafficlight to day n my car low oil pressure went off it bib about 5 times can u guys tell me why my low pressure oil light went off? check oil n normal,other than that what should i do,psl TQ. :)
Top
 Profile  
 
 
 Post subject: Oil
Posted: Mon May 26, 2008 7:36 pm 
Getting Side Ways
Offline

Posts: 652

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

Could be faulty sender. Could be in need of top up. Oil too thin. It is normal in hot weather or with ac on for it to come on at idle here and there.
Top
 Profile  
 
 
Posted: Mon May 26, 2008 8:32 pm 
Getting Side Ways
Offline

Age: 30

Posts: 1087

Joined: 1st Sep 2007

Ride: '07 LT XR5

Power: 133 rwkw

Location: sydney
NSW, Australia

id say oil too thin.
does it do it after a while? ie you've been driving for a while and the engine is either hot or been in operating temp for quite a while?

i had this, the pressure was fine cold but once it got warmed up and after 30min of driving it would go off.

changed to 15w-60 oil and now its boootiful

 

_________________

So much RAM the motherboard twisted off the POST.

I lost 3 cylinders... but gained a turbo...
Proud owner of an '07 XR5Turbo

Top
 Profile  
 
 
Posted: Mon May 26, 2008 8:44 pm 
Fordmods Newbie
Offline

Age: 45

Posts: 18

Joined: 25th Nov 2006

Gallery: 1 images

Location: Melbourne
VIC, Australia

oil to thin huh?ok co'z i used castrol 15w-40,thanks lot.
Top
 Profile  
 
 
Posted: Tue May 27, 2008 9:09 am 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 863

Joined: 26th Nov 2007

Gallery: 20 images

Ride: XH Ute / AU3 V8 Wagon

Location: Bris-Vegas
QLD, Australia

I had the same problem with 10w40, I now run Castrol 15w50, all good. I think the 60 weight is getting a bit heavy for an OHC engine. Hope this helps.

 

_________________

Yes, I own a Ute. No, I won't help you move!

EL Wagon Build Thread http://www.fordmods.com/the-garage-f53/sooty72-s-ef-futura-wagon-long-term-project-t90025.html
XH Ute Thread http://www.fordmods.com/post1138970.html#p1138970

Top
 Profile  
 
 
Posted: Tue May 27, 2008 6:03 pm 
Getting Side Ways
Offline

Age: 30

Posts: 1087

Joined: 1st Sep 2007

Ride: '07 LT XR5

Power: 133 rwkw

Location: sydney
NSW, Australia

yeah i agree that the 60 is probably overkill. id say 50 will be the best

 

_________________

So much RAM the motherboard twisted off the POST.

I lost 3 cylinders... but gained a turbo...
Proud owner of an '07 XR5Turbo

Top
 Profile  
 
 
Posted: Tue May 27, 2008 6:28 pm 
Smokin em up
Offline
User avatar

Age: 49

Posts: 298

Joined: 23rd Nov 2007

Gallery: 5 images

Ride: 03 BA

Location: st marys
NSW, Australia

did u check how much oil in motor.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 30 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 4:03 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names