Fordmods Logo

OIL PRESSURE 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: OIL PRESSURE
Posted: Tue Aug 07, 2007 9:08 pm 
Oompa Loompa
Offline

Age: 45

Posts: 34

Joined: 17th Jul 2006

Location: blacktown
NSW, Australia

Today i noticed the oil pressure gauge reading at the last mark before the red at the high end of the gauge . has anyone else had this happen . I'm hopeing that it is the sender unit that is stuffed.

 

_________________

2.5 CAT BACK , TICKFORD ENHACEMENT SUSPENSION, AND THE USUAL MODS

Top
 Profile  
 
 
Posted: Tue Aug 07, 2007 9:42 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

happens all the time!

95% sender unit.

and sometimes its the cluster, altho.. this usually happens in EF's I've found out.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
Posted: Tue Aug 07, 2007 9:44 pm 
Fordmods Junkie
Offline
User avatar

Age: 31

Posts: 1175

Joined: 23rd Mar 2005

Gallery: 6 images

Ride: 1994 ED Fairmont

Location: Brisbane
QLD, Australia

Krytox wrote:
happens all the time!

95% sender unit.

and sometimes its the cluster, altho.. this usually happens in EF's I've found out.


yeah id put my money on the EF dash...dads ef dash is very twitchy. oil pressure will sit full up the end of the gauge fuel will jump from Full to empty etc...

 

_________________

1994 ED Fairmont Champaign Gold - AU Series II Intech 4.0L - EL EFI - Thermo Fans - 4.11 LSD - Pacemaker 4480 Into Custom 3" Exhaust - Shift Kit
In Progress: EL 4 Speed Auto- 3000 STALL - To be fitted
EF Tickford Race Spec Head Port- In the shop
Custom SureCam - Chiptorque

Top
 Profile  
 
 
Posted: Wed Aug 08, 2007 9:08 am 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 2705

Joined: 6th Nov 2004

Gallery: 11 images

Ride: 2009 FG XR6 Sedan

Location: Melbourne
VIC, Australia

Check the terminal on the oil sender first, clean it and reconnect.
Top
 Profile  
 
 
 Post subject: oil pressure
Posted: Wed Aug 08, 2007 7:27 pm 
Oompa Loompa
Offline

Age: 45

Posts: 34

Joined: 17th Jul 2006

Location: blacktown
NSW, Australia

yeh was the sender happy it didn't cost a fortune :D

 

_________________

2.5 CAT BACK , TICKFORD ENHACEMENT SUSPENSION, AND THE USUAL MODS

Top
 Profile  
 
 
Posted: Thu Aug 09, 2007 3:32 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 4285

Joined: 8th Dec 2004

Gallery: 25 images

Ride: EB2 Ghia,Mighty Boy,Eb1 Xr8 5spd

Location: ** In the Shed! **
VIC, Australia

I have a Hi-Vol oil pump in my EB with the std sensor. At idle i've got oil pressure like std, but when i get the boot into it, say 1800+ rpm, i'm not all that far off the red warning area. Still running the std oil pressure sensor, so the readings i believe are wrong.

Cheers

ToranaGuy

 

_________________

I am the ToranaGuy!|74 Lh Torana Turbo|78 Hz PanelVan|86 Mighty Boy Ute|93 EB2 Ghia,GT Mockup,5spd,LPGI,Full Leather|2 x EB Xr8 5spd's|FS [VIC]: Wrecking - Eb XR8 - Parts available |Build Thread|Ebay Items - Ford Parts|

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 12:14 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names