Fordmods Logo

power steer and rad cap questions 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: power steer and rad cap questions
Posted: Sat Mar 12, 2011 5:01 pm 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

Ok, after a few hundred ks of continuous driving my steering creaks at low speed, im thinking its when it heats up the fluid thins out and then causes the creaking. Any ideas on this one?
Also, I have a coolant leak when the system is at full pressure. It also holds pressure for ages.
Can I drive home from nelsons bay to coffs with the resivour cap loose?
Top
 Profile  
 
 
 Post subject: Re: power steer and rad cap questions
Posted: Sat Mar 12, 2011 8:14 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

87SIlude wrote:
Ok, after a few hundred ks of continuous driving my steering creaks at low speed, im thinking its when it heats up the fluid thins out and then causes the creaking. Any ideas on this one?
Also, I have a coolant leak when the system is at full pressure. It also holds pressure for ages.
Can I drive home from nelsons bay to coffs with the resivour cap loose?


No...unless you want fluid leeching out all over the road.

I would suggest either getting a new cap or take constant stops to check coolant level/pressure. If the car temp is fine, it should be okay...coolant system should be able to hold pressure up to the pressure stamped on the cap (unless it is broken then it will most likely stay closed or open earlier).

Have you checked your power steering fluid level? It may be running low and while you cruise along the fluid might be running a little low which pushes air into the system which you don't want.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: power steer and rad cap questions
Posted: Sun Mar 13, 2011 8:24 am 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

Yea that's what I was thinking.
Temp stays low. Really low. Dosnt even reach N (eb) even when the coolant lights on. Its just a leak somewhere, I am sus on the rad cap so ill buy another, I don't think its releasing pressure.

And my steering level is good, but the fluid is oooold as frig so I might drop it out.
Thanks
Top
 Profile  
 
 
 Post subject: Re: power steer and rad cap questions
Posted: Sun Mar 13, 2011 10:30 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

87SIlude wrote:
Yea that's what I was thinking.
Temp stays low. Really low. Dosnt even reach N (eb) even when the coolant lights on. Its just a leak somewhere, I am sus on the rad cap so ill buy another, I don't think its releasing pressure.

And my steering level is good, but the fluid is oooold as frig so I might drop it out.
Thanks


I think if there isn't enough coolant, the needle actually sits a normal operating temperature even if the car is running hot...so you may actually cooking your engine without knowing it. I know this is the case for ELs. So I would suggest checking this out ASAP and top up frequently.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: power steer and rad cap questions
Posted: Sun Mar 13, 2011 6:41 pm 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

Always has coolant in it man. The light comes on steady when the coolant reaches below the sensor, wich is halfway down the resiviour. And that's when I pull over and fill her up.
So its not running with no coolant and it dosnt get hot. Drove almost 500ks today and the rockercover was still tollerable to lean on.
I found the problem is the side tank sepperates from the core slightly and leaks from there. Will be attmepting to fix it.
Thanks
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 10:18 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names