Fordmods Logo

really bad fuel economy...help please 

 

Page 2 of 2 [ 17 posts ] Go to page Previous  1, 2

 
Posted: Sat Dec 23, 2006 12:01 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2396

Joined: 25th Sep 2005

Gallery: 9 images

Ride: Da Maverick & xe ute

Location: Upper FTG. melbourne
VIC, Australia

nice reply there :P i got one problem with that tho, my car is a manual :S

 

_________________

Mods: sprint kit, steeda short shift, svo lip, El handles, El Air intake, au xr wheels, lukey cat back, jbl focal and pioneer sterio <--- Sold

Xe ute - Bright green with 302

Da maverick - Straight gas turbo

Top
 Profile  
 
 
Posted: Sat Dec 23, 2006 3:28 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

Has anybody mentioned to check for splits in the hose for the MAP sensor, small splits will cause a slight increase in fuel consumption. A blocked fuel pressure regulator can do the same. Also check distributor cap & rotor for condition &, timing
Did you change the oil when you cooked it? because the oil will be stuffed.
When new radiator was fitted, was the cooling system flushed out?

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 17 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 6:48 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names