Fordmods Logo

Revving problems still haha 


Page 1 of 1 [ 1 post ] 

 Post subject: Revving problems still haha
Posted: Fri Jan 14, 2005 11:31 pm 
Getting Side Ways

Posts: 1687

Joined: 5th Nov 2004

Gallery: 5 images

Ride: 1994 ED Ricer

Location: Perth
WA, Australia

I was racing at the Motorplex on wed night.
1st gear is fine to 5500rpm
2nd gear stops revving out at 4900 rpm
and when i changed into 3rd the car felt like it had a flat spot and struggled for a 1000rpm then it was fine up to 4700 when i had to change into 4th(beacsue it wont rev any higher). What could have caused this flat spot? It was s**t because that was the point where the vl turbo got passed me, but once i was over the 'flat spot' i started catching him again but it was to late! :twisted:

Few people have suggested its an ignition problem?? Not enough spark or something?
But funny that,
My smartlock system is being a pain in the a**. When you try to start the car the thing wont even turn over.. So push the handbrake in and realase it the car will start..... Sometimes after a big rev the engine just turns off.. I try to start it again and it will turn over but not fire... So im guessing a spark problem. ( had to push it off the start line at the plex... not cool :P lol)
If i let the car rest for a 30 mins or so it will start up fine.

Could all these problems be caused by an Ignition related problem? Ie. coil or dizzy rotor or something? I would just love to get a few more opinions before i start taking s**t out and replacing it...

Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: skidmark, syoungie and 18 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 22, 2016 10:45 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names