Fordmods Logo

same old air bag problem 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: same old air bag problem
Posted: Wed Jun 23, 2010 2:08 pm 
Parts Gopher
Offline

Posts: 67

Joined: 3rd Feb 2007

Location: melbourne
VIC, Australia

ok its a el classic with 2 airbags
ive disconnected the wiring loom and connected another clockspring and airbag from another car, ive also disconnected the airbag module and connected another module with still the same problem
the airbag light comes from off and slowly lights up and stays on, eventually it blows the fuse
any ideas what else it could be
Top
 Profile  
 
 
 Post subject: Re: same old air bag problem
Posted: Wed Jun 23, 2010 2:21 pm 
Getting Side Ways
Offline

Age: 22

Posts: 613

Joined: 13th Mar 2010

Ride: EF Falcon Monti

Location: Central Coast
NSW, Australia

have you pulled the dash out previous to this? if so, you may want to double check all plugs for the column are plugged in and the sensor on the far passengers side is plugged in (look for the fluoro yellow conduit, if there is a plug without anything on the end, you have forgotten to plug the sensor in). If you havent done so, it could also be a faulty airbag or one of the 3 sensors are screwing around with errors.

 

_________________

BANNED USER

Top
 Profile  
 
 
 Post subject: Re: same old air bag problem
Posted: Wed Jun 23, 2010 2:24 pm 
Parts Gopher
Offline

Posts: 67

Joined: 3rd Feb 2007

Location: melbourne
VIC, Australia

havnt pulled the dash out, ive already tried another airbag in the drivers side
Top
 Profile  
 
 
 Post subject: Re: same old air bag problem
Posted: Wed Jun 23, 2010 2:27 pm 
Getting Side Ways
Offline

Age: 22

Posts: 613

Joined: 13th Mar 2010

Ride: EF Falcon Monti

Location: Central Coast
NSW, Australia

best bet is to find someone with a scanner that scans for error codes then it should pin-point the problem

 

_________________

BANNED USER

Top
 Profile  
 
 
 Post subject: Re: same old air bag problem
Posted: Wed Jun 23, 2010 3:22 pm 
Getting Side Ways
Offline

Posts: 2448

Joined: 5th Nov 2004

Gallery: 7 images

Location: Brisbane
QLD, Australia

Betting for something else - that its blowing the fuse tells me that one of the wires is shorted or crimped - perhaps when you had the dash out

Nigel
Top
 Profile  
 
 
 Post subject: Re: same old air bag problem
Posted: Wed Jun 23, 2010 3:24 pm 
Getting Side Ways
Offline

Age: 22

Posts: 613

Joined: 13th Mar 2010

Ride: EF Falcon Monti

Location: Central Coast
NSW, Australia

Apparently he hasnt had the dash out but how did he manage to replace the airbag module?

 

_________________

BANNED USER

Top
 Profile  
 
 
 Post subject: Re: same old air bag problem
Posted: Wed Jun 23, 2010 3:51 pm 
Parts Gopher
Offline

Posts: 67

Joined: 3rd Feb 2007

Location: melbourne
VIC, Australia

havnt pulled the dash out, ive already tried another airbag in the drivers side
Top
 Profile  
 
 
 Post subject: Re: same old air bag problem
Posted: Wed Jun 23, 2010 3:53 pm 
Parts Gopher
Offline

Posts: 67

Joined: 3rd Feb 2007

Location: melbourne
VIC, Australia

just unplugged it and plugged in another module, pretty simple, cable tied it to the steel frame for earth
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 25 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 12:12 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names