Fordmods Logo

still got problems... dizzy or computer Ea 3.9 cfi auto 

 

Page 1 of 1 [ 9 posts ] 

 
 Post subject: still got problems... dizzy or computer Ea 3.9 cfi auto
Posted: Mon Aug 14, 2006 1:35 pm 
Fordmods Newbie
Offline

Age: 40

Posts: 9

Joined: 24th Jul 2006

Ride: EA Frailcan

Location: Parramatta
NSW, Australia

My EA still keeps conking out. at first i thought was a fuel problem but once the engine has warmed up the ignition just cuts out. but i get spark when the starter is engaged(briefly).
I tried new coil and leads but no joy.
could be dizzy not sure, but the computer is giving out different fault codes every time I run a diagnostic (even an identifier code for a manual 3.9 cfi, but i may have misread).
Does the computer in these cars ever have problems like these or is there something else wrong with my car.
Top
 Profile  
 
 
Posted: Mon Aug 14, 2006 2:13 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1966

Joined: 13th Aug 2005

Ride: 2000 Au wagon

Location: some where in nsw
NSW, Australia

replace the distributor.

 

_________________

Image

Top
 Profile  
 
 
Posted: Mon Aug 14, 2006 2:17 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

hi
its more than likely your tfi module on your dizzy...
Top
 Profile  
 
 
Posted: Mon Aug 14, 2006 2:40 pm 
Fordmods Newbie
Offline

Age: 40

Posts: 9

Joined: 24th Jul 2006

Ride: EA Frailcan

Location: Parramatta
NSW, Australia

what's a tfi module, what's it do? can it be replaced easily and cheaply?
Top
 Profile  
 
 
Posted: Mon Aug 14, 2006 3:02 pm 
Moderator
Offline

Posts: 14513

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

hi
the tfi module is screwed to the side of your distributor and your wiring plugs into it it can be replaced fairly easily..
they are a comon thing that fails in the ea to ed falcons..
i had a similar problem a couple of months back the car would run fine then once it had warmed up it would sometimes just stop!! no spark?
i would let it sit for about 30 mins and it would start and run again..
it did this for about 1 month on and off and one day it just stoped and didnt go no more.. so i replaced the tfi module and i havnt had any isues with it since..
Top
 Profile  
 
 
Posted: Mon Aug 14, 2006 3:13 pm 
Getting Side Ways
Offline
User avatar

Posts: 3115

Joined: 20th Dec 2004

Ride: Falcon

Location: Adelaide
SA, Australia

Sounds like the TFI to me, and yeah its a common problem. Just make sure you use heat paste when you replace it otherwise youll burn the new one out very quickly

 

_________________

Stoke me a clipper, I'll be back for Christmas

Top
 Profile  
 
 
Posted: Mon Aug 14, 2006 5:53 pm 
Fordmods Newbie
Offline

Age: 40

Posts: 9

Joined: 24th Jul 2006

Ride: EA Frailcan

Location: Parramatta
NSW, Australia

heat paste you say? Is that applied to the mounting point of the tfi? Is it used as a heat tranfer/ heat sink?


thanx for your replies guys, your help is invaluable.
I was thinking of giving up the falcon habit and going back to old school carbie and points, but the ford mods support base is unbelievably helpful

You guys rock!...

no, i'm not kissing butt...
... I think.
Top
 Profile  
 
 
Posted: Mon Aug 14, 2006 6:13 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1966

Joined: 13th Aug 2005

Ride: 2000 Au wagon

Location: some where in nsw
NSW, Australia

yeah,,smear it over the mateing areas

 

_________________

Image

Top
 Profile  
 
 
Posted: Mon Aug 14, 2006 10:49 pm 
Getting Side Ways
Offline

Age: 34

Posts: 756

Joined: 21st Nov 2005

Gallery: 25 images

Ride: 1999 AU futura

Location: griffith
NSW, Australia

Replace your distributor.Its cheaper and you can pick one up down at your local repco joint.

 

_________________

COMING SOON,XD WITH A TURBO...CLEVO STYLE

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 9 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 2:13 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names