Fordmods Logo

Tickford 4 litre wont start HELP 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: Tickford 4 litre wont start HELP
Posted: Thu Mar 24, 2016 1:44 pm 
Fordmods Newbie
Offline

Age: 47

Posts: 1

Joined: 2nd Feb 2016

Ride: ford el fairmont ghia

Location: Perth
WA, Australia

I have a 1998 el Fairmont ghia (4 litre Tickford engine ).
I have had the head of to do the valves after refitting the head and trying to start ,the engine will crank and seems to fire but wont run ,can anyone help.
Top
 Profile  
 
 
 Post subject: Re: Tickford 4 litre wont start HELP
Posted: Wed Mar 30, 2016 10:29 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000487

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

got the plug leads on the right plugs?

all the plugs for the wiring and fuel connected?

did you pull the fuel pump relay and forget to re install?

 

_________________

RIP SCOTT

Top
 Profile  
 
 
 Post subject: Re: Tickford 4 litre wont start HELP
Posted: Wed Mar 30, 2016 11:28 pm 
Moderator
Offline

Posts: 14510

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

are the fuel lines on the right way? eg return to feed
Top
 Profile  
 
 
 Post subject: Re: Tickford 4 litre wont start HELP
Posted: Thu Mar 31, 2016 8:35 pm 
Fordmods Junkie
Offline
User avatar

Age: 38

Posts: 1000487

Joined: 6th Nov 2004

Gallery: 2 images

Ride: AUXR6 HP With Ducati SupA Bike!

Location: Perth
WA, Australia

TROY. wrote:
are the fuel lines on the right way? eg return to feed


i did not think they could go on the wrong way

 

_________________

RIP SCOTT

Top
 Profile  
 
 
 Post subject: Re: Tickford 4 litre wont start HELP
Posted: Thu Mar 31, 2016 8:44 pm 
Moderator
Offline

Posts: 14510

Joined: 7th Nov 2004

Ride: ford falcon au3 xr8

Location: a shit suburb in sydney
NSW, Australia

yea they can although one line is slightly shorter than the other but both quick connect lines are the same type
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: PhilsMont and 30 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed May 24, 2017 8:40 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names