Fordmods Logo

Ticking + shuddering + crazy idle 

 

Page 2 of 2 [ 18 posts ] Go to page Previous  1, 2

 
 Post subject: .
Posted: Sun Sep 28, 2008 8:49 pm 
Tyre Shredder
Offline

Age: 30

Posts: 340

Joined: 7th Sep 2008

Gallery: 3 images

Ride: EF Futura

Location: Blactown, sydney
NSW, Australia

has stopped doing it since i put on the pod filter & piping on...think i had a airflow restiction.

 

_________________

EF futura in the build.
http://www.fordmods.com/forums/ef-futur ... 70086.htmlImage

wtb:ef fairmont bonnet,lights & a set of ssl springs

Top
 Profile  
 
 
Posted: Sun Sep 28, 2008 8:53 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 721

Joined: 31st Dec 2005

Ride: EF V8 Futura, 180sx

Location: Brisbane, Burpengary
QLD, Australia

k was the factory air filter dirty?

 

_________________

Ford EF Futura Black
18" koya Strykers, AU engine with port and polish EB head, crow valve springs, standard cam, Large aftermarket RX7 turbo, T5 manual 3" intercooler piping, 600x300x100 intercooler core, MSII with innovate wideband O2 sensor and guage. BA F6 bodykit

Top
 Profile  
 
 
Posted: Mon Sep 29, 2008 11:38 am 
Getting Side Ways
Offline

Age: 30

Posts: 1087

Joined: 1st Sep 2007

Ride: '07 LT XR5

Power: 133 rwkw

Location: sydney
NSW, Australia

good to hear mate.

 

_________________

So much RAM the motherboard twisted off the POST.

I lost 3 cylinders... but gained a turbo...
Proud owner of an '07 XR5Turbo

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 18 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 3:29 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names