Fordmods Logo

Too much oil pressure - ED block / EF Head 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: Too much oil pressure - ED block / EF Head
Posted: Fri Dec 26, 2008 11:17 am 
Fordmods Newbie
Offline

Posts: 13

Joined: 21st Aug 2008

Ride: XR6 Ute

Location: sydney
NSW, Australia

I've just fitted a rebuilt 4 litre ED block / EF Head combination (included new standard oil pump) and on firing the 1st time it popped the oil filter O-ring. I tightened it up a bit more which caused the oil pressure to go over 100 PSI on idle (mechanical oil gauge) within seconds of starting. Has anyone come across this before or got any ideas? :(

 

_________________

Go fast turn left

Last edited by cd11 on Fri Dec 26, 2008 12:04 pm, edited 1 time in total.

Top
 Profile  
 
 
Posted: Fri Dec 26, 2008 11:52 am 
Getting Side Ways
Offline

Age: 31

Posts: 2337

Joined: 25th Apr 2008

Ride: Boxcar Love

Location: Brisbane
QLD, Australia

What kind of oil pump did you fit??? High volume or high pressure?

 

_________________

Commodore australia's favorite car??? What a load of s**t
Image

Top
 Profile  
 
 
Posted: Fri Dec 26, 2008 12:06 pm 
Fordmods Newbie
Offline

Posts: 13

Joined: 21st Aug 2008

Ride: XR6 Ute

Location: sydney
NSW, Australia

It was just a standard oil pump, nothing fancy.

 

_________________

Go fast turn left

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 3:47 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names