Fordmods Logo

Trouble stopping car. Brakes or what? 

 

Page 2 of 2 [ 26 posts ] Go to page Previous  1, 2

 
Posted: Thu Dec 23, 2004 9:23 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 5924

Joined: 5th Nov 2004

Gallery: 7 images

Ride: Ford FPV FG F6 310

Power: 149 rwkw

Location: Brisbane
QLD, Australia

the plastic booster cost me $138, im pretty sure i ordered it from coventry or national parts in brisbane.
the calipers wouldn't be seized up would they?

 

_________________

NEW RIDE - FPV FG F6 6spd Auto. 12.26@114MPH, 1.88 60FT on Cheapy Tyres with 38PSI - Stock except K&N filter!

R.I.P. BF XR6 Turbo - You will not be forgotten :( 12.06@120MPH

Top
 Profile  
 
 
Posted: Sat Dec 25, 2004 12:36 pm 
Smokin em up
Offline
User avatar

Age: 34

Posts: 258

Joined: 9th Dec 2004

Gallery: 4 images

Ride: EL falcon - Skyline r33

Location: Sydney
NSW, Australia

smoke_rubber wrote:
the plastic booster cost me $138, im pretty sure i ordered it from coventry or national parts in brisbane.
the calipers wouldn't be seized up would they?

naa they all stock disks and calipers .

First thing im gonan do is put some real nice griping brake pads before i do any more changed.

 

_________________

It's set up like a deck of cards, They're sending us to early graves. For all the diamonds, they'll use a pair of clubs to beat the spades.

RATM

Top
 Profile  
 
 
Posted: Sat Jan 15, 2005 4:49 pm 
ACT Cruise Moderator
Offline
User avatar

Age: 36

Posts: 6275

Joined: 24th Nov 2004

Ride: '06 BF GT-P

Power: 293 rwkw

Location: Canberra
ACT, Australia

Just got my car serviced yesterday, and got all four pads replaced. Now before I had lucas pads, now Ford OEM pads (I should've reminded them performance pads!).

I'm experiencing similar problems.

Sfot break pedal, takes nearly half way to get anything. And I did a road test today, 80KM/H jump on brakes, took about twice as long to stop as I'd expect (and had just the day before). Felt like sliding on ice - not a nice feeling, not being able to trust your brakes. Hence it's going back first thing Monday.

 

_________________

1998 DL LTD in Sparkling Burgundy, daily, 302W, stereo, slow - 97.5rwkw
2006 BF GT-P in Ego, mods. 293rwkw - 12.427@109 - 0-1000m 24.838@221

Top
 Profile  
 
 
Posted: Sat Jan 15, 2005 4:52 pm 
Stock as a Rock
Offline
User avatar

Age: 47

Posts: 189

Joined: 6th Nov 2004

Gallery: 5 images

Ride: FGX xr6

Location: Melbourne
VIC, Australia

New brake pads take time to bed in to work properly. Give it time Grasshopper then try them again.

p.s. unless you have racing pads in your car they are supposed to be bed in without getting too hot. i.e. no hard stops for about 1000km.

 

_________________

-Dave

If you can't do the speed limit, get the F*ck out of the right lane!
Image

Top
 Profile  
 
 
Posted: Sat Jan 15, 2005 4:55 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 5924

Joined: 5th Nov 2004

Gallery: 7 images

Ride: Ford FPV FG F6 310

Power: 149 rwkw

Location: Brisbane
QLD, Australia

Nanger wrote:
p.s. unless you have racing pads in your car they are supposed to be bed in without getting too hot. i.e. no hard stops for about 1000km.

yeah i didn't' hop onto mine for around 1000km, but i notice the difference a good set of pads and rotors can do for a car.

 

_________________

NEW RIDE - FPV FG F6 6spd Auto. 12.26@114MPH, 1.88 60FT on Cheapy Tyres with 38PSI - Stock except K&N filter!

R.I.P. BF XR6 Turbo - You will not be forgotten :( 12.06@120MPH

Top
 Profile  
 
 
Posted: Sat Jan 15, 2005 5:41 pm 
ACT Cruise Moderator
Offline
User avatar

Age: 36

Posts: 6275

Joined: 24th Nov 2004

Ride: '06 BF GT-P

Power: 293 rwkw

Location: Canberra
ACT, Australia

I've got DBA slotted rotors, and had Lucas high end pads. And I must say I wasn't expecting toneed a pad change. Now I've got excess pedal travel, and brakes I don't feel safe with.

 

_________________

1998 DL LTD in Sparkling Burgundy, daily, 302W, stereo, slow - 97.5rwkw
2006 BF GT-P in Ego, mods. 293rwkw - 12.427@109 - 0-1000m 24.838@221

Top
 Profile  
 
 
Posted: Sat Jan 15, 2005 5:42 pm 
Stock as a Rock
Offline
User avatar

Age: 47

Posts: 189

Joined: 6th Nov 2004

Gallery: 5 images

Ride: FGX xr6

Location: Melbourne
VIC, Australia

Could also be that they haven't bled them properly if they feel too spongy.

 

_________________

-Dave

If you can't do the speed limit, get the F*ck out of the right lane!
Image

Top
 Profile  
 
 
Posted: Sat Jan 15, 2005 5:45 pm 
ACT Cruise Moderator
Offline
User avatar

Age: 36

Posts: 6275

Joined: 24th Nov 2004

Ride: '06 BF GT-P

Power: 293 rwkw

Location: Canberra
ACT, Australia

yeah, I am going back.

I just wish I had the time to service the car myself. Would'nt have half the worries.

 

_________________

1998 DL LTD in Sparkling Burgundy, daily, 302W, stereo, slow - 97.5rwkw
2006 BF GT-P in Ego, mods. 293rwkw - 12.427@109 - 0-1000m 24.838@221

Top
 Profile  
 
 
Posted: Mon Jan 17, 2005 1:13 am 
Smokin em up
Offline

Age: 31

Posts: 204

Joined: 6th Nov 2004

Gallery: 2 images

Ride: EL Futura

Location: Kurri Kurri
NSW, Australia

yer...if uve replaced the master cylinder id be looking at 3 things.

1. Air in the brake lines (1st as its easiest to fix)

2. leaks in any of the calipers as this will be visable and possibly be the cause of 1...as the leaks can also suck in air...causing soft brakes and more compression in the air...therefore less pressure...less fluid blah blah

3. booster and master cylinder...other than that i am out of ideas...theres not a lot else to go wrong, brake lines are not a common thing to messup...but i guess you can do it.
Top
 Profile  
 
 
Posted: Tue Jan 18, 2005 12:20 pm 
Stock as a Rock
Offline

Age: 34

Posts: 118

Joined: 5th Nov 2004

Gallery: 5 images

Ride: BA XR6 Turbo

Location: Sydney
NSW, Australia

If its making noises when you brake, tis the brake booster. The idle should change and sound different when you apply the pedal.

I had the same problem with my XE! But it all happened over the period of about 10 mins and I had no brakes. Lucky it was early morning or I would have got T-boned cos I went through a set of lights!

 

_________________

fast1

Top
 Profile  
 
 
Posted: Tue Jan 18, 2005 5:16 pm 
ACT Cruise Moderator
Offline
User avatar

Age: 36

Posts: 6275

Joined: 24th Nov 2004

Ride: '06 BF GT-P

Power: 293 rwkw

Location: Canberra
ACT, Australia

Well I've got mine back, two things...

1. They put soft a** pads on - hopefully I'll go through htese quickly, and go back to the lucas pads I had before :twisted:

2. They didn't bleed the system properly.

 

_________________

1998 DL LTD in Sparkling Burgundy, daily, 302W, stereo, slow - 97.5rwkw
2006 BF GT-P in Ego, mods. 293rwkw - 12.427@109 - 0-1000m 24.838@221

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 2  [ 26 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 8:26 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names