Fordmods Logo

weird idle issues - need a real diagnostic expert 


Page 1 of 1 [ 2 posts ] 

 Post subject: weird idle issues - need a real diagnostic expert
Posted: Tue Apr 21, 2009 10:57 pm 
Getting Side Ways
User avatar

Posts: 3363

Joined: 27th Dec 2004

Gallery: 4 images

Ride: MCMXCV Falcon

Location: G town
VIC, Australia

symptoms are (ef 6cyl): kind of rev hangs on trailing throttle then revs drop low when almost stopped and then gives a little rev up before settling down to idle reasonably well...also idle seems to drop a bit low at times....also it used to have little rev ups (flares) every 60 seconds or so, although since changing to a hotter thermostat this seems to have gone away!!! go figure!

so after trying a million things i thought id have a look at the tps (throttle position sensor)...

the voltage(pin 89) at closed throttle (idle) is around .62 - this within the range - and its smooth all the way to full the tps itself seems to be ok....

now the weird thing is that if i back of the throttle at speed (cruise say 70kmh) the voltage seems to stay around .67 and will not return to .62 till i have stopped....whats going on here???

now another strange thing is that the more electrical load i have on the motor the more the voltage if i have the high beams, fan, wipers on etc the voltage can drop below .5!!!! it idles very low when this happens(measured at pin 89 and using the cig lighter earth wire)....

also as the electrical loads go up the dash voltage meter drops quite low but when i measure the voltage at the batter terminals it never drops below 13.6V no matter what i have switched on...

now i thought the ecu kept the voltage referenced at 5v for the seems the ecu is not getting full voltage or has a bad earth (gust guessing at this stage)

where would the ecu earths be?




 Post subject: Re: weird idle issues - need a real diagnostic expert
Posted: Wed Apr 22, 2009 12:33 pm 
Fordmods Addict
User avatar

Age: 30

Posts: 7958

Joined: 1st Jun 2005

Gallery: 13 images

Ride: Falcon

Power: 237 rwkw

Location: Melbourne
VIC, Australia

ECU has an earth on the screw that holds the bracket, but I would go right through the major earths, including dash loom earth under crash pad.
I like to upsize or supplement the battery to chassis earth personally, I found that solved most of the voltage drop problems in both my EDs, this was only at high load though.
Which just reminds me I haven't done one in the XR8, gotta remember to do that, thanks gogetta :lol:

Also that TPS behaviour sounds a bit weird to me too, like not entirely a voltage drop issue?
Have you got another one you can test? I mean it's statistically unlikely even if you grab a f**k one that its gonna show the exact same issue, so it might be useful for diagnosis?
I'm no expert, just something I'd try.

Hopefully that gives you some ideas anyway.



ED XR8 Sprint - S-Trim, V500, 249rwkw
BF MKII F6 Tornado - 237rwkw

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: MSNbot Media and 20 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Mon Oct 24, 2016 11:20 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names