Fordmods Logo

weird idle on ed fairmont 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: weird idle on ed fairmont
Posted: Thu Dec 15, 2011 10:50 am 
Stock as a Rock
Offline
User avatar

Age: 24

Posts: 130

Joined: 27th Jul 2011

Gallery: 2 images

Ride: 93 ed fairmont ghia

Location: Bulli
NSW, Australia

hi ive got a werid idle on my fairmont, sometimes when i pull up to the lights it will idle high around 1300rpm and then it drops down to like 400rpm if i sit there for the duration of the lights. anyone why why its doing this? it can also does its only thing and pick up in revs and drops down slightly on its way back down to settle to normal revs. sounds a bit weird at the lights next to other people. it also revs too high when the car does a cold start up..i know it is surposed to like "choke" but yeah..
car also has a bit of rev hang, is a converted manual... maybe i need to j3 it?just doesnt sound like a vaccum hose other wise it would always be a high idle.. also i remember reading somewhere to adjust base idle to 500rpm by unpluging the isc , adjusting it then re connecting it? is that correct?
cheers

 

_________________

ED Fairmont Ghia. t5 conversion w h/d exedy, 3:45:1 lsd, pacemaker extractors, 2.5" custom exhaust, waggott cam,K&N high flow panel filter, TI performance chip w/ 4 tune switch(2 ED, 2 EL tunes) king 18's, el thermo fan w/ Davis Craig switch. 5000K hids,led lighting, doof box in boot.

Top
 Profile  
 
 
 Post subject: Re: weird idle on ed fairmont
Posted: Thu Dec 15, 2011 11:32 am 
Stock as a Rock
Offline
User avatar

Age: 24

Posts: 130

Joined: 27th Jul 2011

Gallery: 2 images

Ride: 93 ed fairmont ghia

Location: Bulli
NSW, Australia

c james wrote:
it can also does its only thing and pick up in revs and drops down slightly on its way back down to settle to normal revs. sounds a bit weird at the lights next to other people.


wow sorry, that makes no sence at all i was doing it on my phone, i ment to say...
" it also can pick up and drop revs by its self, its only slighty but with an exhaust its noticable.." sorry!

 

_________________

ED Fairmont Ghia. t5 conversion w h/d exedy, 3:45:1 lsd, pacemaker extractors, 2.5" custom exhaust, waggott cam,K&N high flow panel filter, TI performance chip w/ 4 tune switch(2 ED, 2 EL tunes) king 18's, el thermo fan w/ Davis Craig switch. 5000K hids,led lighting, doof box in boot.

Top
 Profile  
 
 
 Post subject: Re: weird idle on ed fairmont
Posted: Thu Dec 15, 2011 11:45 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Sounds like my car when I did the conversion on the EL. It would hang high and jump around on idle some times (hunting). Over time it would get better but the hunting was always there and sometimes does hang at around 1100RPM before it drops when stopping.

The only thing that fixed it was the J3 chip. It caused a bit of issue at the beginning when it was learning to idle (would stall sometimes and behave like it had not J3) and after maybe 3 days of solid driving it would stop and idle perfectly fine. No stalling, no idle hunt and no high idle.

Give the base idle adjustment a go first and see how that turns out. If it works then you save yourself some money from getting a J3 chip. In saying that, J3 chip can come in handy if you plan on doing big mods down the road.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: weird idle on ed fairmont
Posted: Thu Dec 15, 2011 2:49 pm 
Stock as a Rock
Offline
User avatar

Age: 24

Posts: 130

Joined: 27th Jul 2011

Gallery: 2 images

Ride: 93 ed fairmont ghia

Location: Bulli
NSW, Australia

phongus wrote:
Give the base idle adjustment a go first and see how that turns out. If it works then you save yourself some money from getting a J3 chip. In saying that, J3 chip can come in handy if you plan on doing big mods down the road.


is the way i said the correct way to adjust base idle. how u descibed the problems sounds exacley like mine. i did get a j3 from ti performance on an EL ecu but i was having dramas with that because i dont know what type of cam i have in the car (pre me owning it and old owner has lost sheats) the car felt like it was missing around the 2000-3000rpm range under light to mid acceleration, giving it a gut full and you wouldnt even happen, ive done alot to try to find what cam it is, bar pulling it out and sending it away to get specs. i think i might try and just get an xr6 tune on my ed ecu with a j3 and see how i go. ti performance has been really good with me. cheers

 

_________________

ED Fairmont Ghia. t5 conversion w h/d exedy, 3:45:1 lsd, pacemaker extractors, 2.5" custom exhaust, waggott cam,K&N high flow panel filter, TI performance chip w/ 4 tune switch(2 ED, 2 EL tunes) king 18's, el thermo fan w/ Davis Craig switch. 5000K hids,led lighting, doof box in boot.

Top
 Profile  
 
 
 Post subject: Re: weird idle on ed fairmont
Posted: Thu Dec 15, 2011 3:04 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

c james wrote:
phongus wrote:
Give the base idle adjustment a go first and see how that turns out. If it works then you save yourself some money from getting a J3 chip. In saying that, J3 chip can come in handy if you plan on doing big mods down the road.


is the way i said the correct way to adjust base idle. how u descibed the problems sounds exacley like mine. i did get a j3 from ti performance on an EL ecu but i was having dramas with that because i dont know what type of cam i have in the car (pre me owning it and old owner has lost sheats) the car felt like it was missing around the 2000-3000rpm range under light to mid acceleration, giving it a gut full and you wouldnt even happen, ive done alot to try to find what cam it is, bar pulling it out and sending it away to get specs. i think i might try and just get an xr6 tune on my ed ecu with a j3 and see how i go. ti performance has been really good with me. cheers


I have a 1673 cam on mine but run an XR6 tune on the J3, works fine with me. As long as it's a manual tune, the idle should work out better for you. See if TI would burn a XR equivalent for you.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 33 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 10:21 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names