Fordmods Logo

When i Accelerate It revs but car dont go HELP!! 

 

Page 1 of 2 [ 19 posts ] Go to page 1, 2  Next

 
 Post subject: When i Accelerate It revs but car dont go HELP!!
Posted: Mon Apr 11, 2011 11:42 am 
Parts Gopher
Offline
User avatar

Age: 26

Posts: 72

Joined: 8th Oct 2009

Gallery: 2 images

Ride: FG Falcon XR6

Location: Gold Coast
QLD, Australia

(Falcon EF 95 Gli) hey guys, lately everytime i put my foot down the car shakes alot but it doesnt take off, about 4- seconds the car will decide to pick up speed. Is pipes clogged or air intake?? im using U91 fuel only if that helps. Im not sure what the go is here so any comments will be great

cheers.

 

_________________

PH4490 Pacemaker Headers
Bullet Hi Flow Cat
2.5" X force Cat Back Mandrel System
K&N Panel Filter
Alteeza Aftermarket Tail Lights
Youtube - http://www.youtube.com/user/straitupmatt

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Mon Apr 11, 2011 11:54 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

Things to check -
Air filter isn't clogged,
Fuel Filter isn't 1,000,000 years old, (as mine was recently when doing the same thing as yours)
Trans fluid level is correct.
Spark plugs aren't fouled.
(And using 95ron (at least) fuel helps too, as might a bottle of injector cleaner.
Hope this helps.

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Mon Apr 11, 2011 12:31 pm 
Parts Gopher
Offline
User avatar

Age: 26

Posts: 72

Joined: 8th Oct 2009

Gallery: 2 images

Ride: FG Falcon XR6

Location: Gold Coast
QLD, Australia

Esteven8 wrote:
Things to check -
Air filter isn't clogged,
Fuel Filter isn't 1,000,000 years old, (as mine was recently when doing the same thing as yours)
Trans fluid level is correct.
Spark plugs aren't fouled.
(And using 95ron (at least) fuel helps too, as might a bottle of injector cleaner.
Hope this helps.


thx mate, ive recently had the sparks and fuel filter replaced but havnt checked the trans fluid ever :/ and i se to pu injector cleaner in but havnt in a while might check it out now.

 

_________________

PH4490 Pacemaker Headers
Bullet Hi Flow Cat
2.5" X force Cat Back Mandrel System
K&N Panel Filter
Alteeza Aftermarket Tail Lights
Youtube - http://www.youtube.com/user/straitupmatt

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Mon Apr 11, 2011 12:55 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

if its auto... it sounds gearbox related. either a stuffed torque converter of the box itself is buggered. Any idea if or when it was last serviced?

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Mon Apr 11, 2011 1:19 pm 
Parts Gopher
Offline
User avatar

Age: 26

Posts: 72

Joined: 8th Oct 2009

Gallery: 2 images

Ride: FG Falcon XR6

Location: Gold Coast
QLD, Australia

yeah its a auto, um it hasnt had a proper service in over 30,000kms ive just been changing stuff my self and gettin mechanics of fix up things that needed to be done. Whats the torque thing you mentioned and could tht also be possibility on the problem?

 

_________________

PH4490 Pacemaker Headers
Bullet Hi Flow Cat
2.5" X force Cat Back Mandrel System
K&N Panel Filter
Alteeza Aftermarket Tail Lights
Youtube - http://www.youtube.com/user/straitupmatt

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Mon Apr 11, 2011 1:53 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

A torque converter is like an automatic clutch, it allows you to stop the car in drive without stalling the engine. It uses oil from the transmission to operate, therefore if the transmission oil is low the torque converter wont work properly.
Its possible that your transmission or torque converter is waiting on pressure to build up before you get any forward motion.

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Mon Apr 11, 2011 4:17 pm 
Getting Side Ways
Offline
User avatar

Age: 27

Posts: 1998

Joined: 31st Dec 2007

Gallery: 9 images

Ride: xc wag's, tnklane wag's

Location: Munruben
QLD, Australia

hehe hyundai accent autos good fun, my dad had 3 replaced under warranty,and finally replaced the car with an au on gas, funnily enough gets better economy now.

 

_________________

Signature removed by moderator.signature must not exceed 120x500 pixles

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Mon Apr 11, 2011 8:56 pm 
Getting Side Ways
Offline

Age: 34

Posts: 1166

Joined: 31st Mar 2005

Gallery: 2 images

Ride: ef falcon, el fairmont ghia

Location: Christchurch
New Zealand

don't think ef's had dipsticks. they do slip when low on fluid, should be first thing to check. defintly sounds auto related
Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Mon Apr 11, 2011 9:09 pm 
Parts Gopher
Offline

Age: 25

Posts: 76

Joined: 2nd Jul 2010

Ride: 96 EF 5 Spd

Location: lara
VIC, Australia

yeh the ef's have a dip stick for the auto its on the exhaust manifold side yellow handle :)
checked my auto oil last week in my ef mont
Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Mon Apr 11, 2011 9:21 pm 
Getting Side Ways
Offline

Age: 40

Posts: 524

Joined: 15th Aug 2010

Ride: Territory SX TX

Location: Townsville
QLD, Australia

Yeah I think EL's were the ones that got the later non dipstick auto... My EB flares about like a drag with a 3 grand stall when its in economy mode (thats a f**k lie in itself, pffft what economy) but funnily click it into power and it changes fine. Will be dropping the EL auto and converter that I have in the shed into the Eb this weekend if the gods are smiling... Anyone want a dummies 3 grand stalled 4 speed???
Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Mon Apr 11, 2011 9:30 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

i know au doesnt have the trans dip stick

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Mon Apr 11, 2011 11:15 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

Troy wrote:
don't think ef's had dipsticks.

Justin-A wrote:
yeh the ef's have a dip stick for the auto its on the exhaust manifold side yellow handle :)
dazza027 wrote:
Yeah I think EL's were the ones that got the later non dipstick auto...

IIRC the later model EFII's did away with the trans dipstick... just to make life that bit more confusing. :)

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Sun Apr 17, 2011 3:55 pm 
Parts Gopher
Offline
User avatar

Age: 26

Posts: 72

Joined: 8th Oct 2009

Gallery: 2 images

Ride: FG Falcon XR6

Location: Gold Coast
QLD, Australia

hey guys thx for the comment's. Well i talked to a mechanic and he said it may be the spark plug leads, if not it may be something with the the coil pack or something,, not sure but yeah. Even when its in idle at light's the car sort of gurgles like it has lack of fuel or oxegen. What u think guys??

 

_________________

PH4490 Pacemaker Headers
Bullet Hi Flow Cat
2.5" X force Cat Back Mandrel System
K&N Panel Filter
Alteeza Aftermarket Tail Lights
Youtube - http://www.youtube.com/user/straitupmatt

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Sun Apr 17, 2011 4:52 pm 
Getting Side Ways
Offline

Age: 26

Posts: 1472

Joined: 11th Jan 2011

Gallery: 5 images

Ride: Vixen Red 09 FG XT

Location: Dalby
QLD, Australia

|| xXFalconXx || wrote:
hey guys thx for the comment's. Well i talked to a mechanic and he said it may be the spark plug leads, if not it may be something with the the coil pack or something,, not sure but yeah. Even when its in idle at light's the car sort of gurgles like it has lack of fuel or oxegen. What u think guys??


is it still doing it?

cause last night i hosed out my engine bay, and a bit of water accidently made its way into my air intake. anyways, short story was it run like a b**ch for a bit. pretty much what you've described, except there was no power at all lol

 

_________________

VIXEN FG XT Previous best - 14.431 @ 99.69mph with minor mods
Currently 14.235 @ 101mph same mods. Bring on the 13's!

Top
 Profile  
 
 
 Post subject: Re: When i Accelerate It revs but car dont go HELP!!
Posted: Tue Apr 19, 2011 10:15 am 
Parts Gopher
Offline
User avatar

Age: 26

Posts: 72

Joined: 8th Oct 2009

Gallery: 2 images

Ride: FG Falcon XR6

Location: Gold Coast
QLD, Australia

yeh i think its still doing it, havnt wanted to try it lol i just hope the old girl hold's out until i have enough for a BA :)

 

_________________

PH4490 Pacemaker Headers
Bullet Hi Flow Cat
2.5" X force Cat Back Mandrel System
K&N Panel Filter
Alteeza Aftermarket Tail Lights
Youtube - http://www.youtube.com/user/straitupmatt

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 19 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 30 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 7:33 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names