Fordmods Logo

wondering engine temp 


Page 4 of 4 [ 49 posts ] Go to page Previous  1, 2, 3, 4

Posted: Sun Aug 21, 2005 9:20 pm 
Getting Side Ways
User avatar

Age: 52

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

mattie wrote:
i have a coolant problem now...and the problem is a lack of it.
the plastic tank over near the air box (but still in the radiator) had been leaking, although we didnt know where the leak was at the time, and yesterday i noticed alot of coolant was burning (steam n smell) so i pulled over, turned the car off as it got to just over half way hot and its normally quite low on heat since au3 snorkel was put on and then i turned the car off and popped the bonnet, when i got 2 the front of the car it just dumped all the coolant everywhere....5 litres of water later we were able to find the leak/crack.
*prays thats its only the tank cracked and not the whole radiator*
i was told if its just the tank i should be up for around $200 to have it replaced but if the radiator is gone i will be up for like $ that about right?

FFFFFFor f**k sake that dear! A tank is about $35 to buy! I was quoted $110 to replace both tanks & seals, & 3 month warranty. Not worth it as I got a new Natrad radiator for $170 & 2 years.



She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Posted: Mon Aug 22, 2005 12:04 am 
Getting Side Ways
User avatar

Age: 32

Posts: 5924

Joined: 5th Nov 2004

Gallery: 7 images

Ride: Ford FPV FG F6 310

Power: 149 rwkw

Location: Brisbane
QLD, Australia

yeah a mate got his radiator for $180.
600 is FAR TOO DEAR!



NEW RIDE - FPV FG F6 6spd Auto. 12.26@114MPH, 1.88 60FT on Cheapy Tyres with 38PSI - Stock except K&N filter!

R.I.P. BF XR6 Turbo - You will not be forgotten :( 12.06@120MPH

Posted: Fri Sep 02, 2005 4:50 pm 
Smokin em up
User avatar

Age: 35

Posts: 258

Joined: 7th Nov 2004

Gallery: 6 images

Ride: '98 EL XR8

Location: Katherine
NT, Australia

I don't know how old this message is, but I had the same problem for a while...

I thought it was the thermostat... but I replaced it with a new one and the problem still existed.

Then the other day, after I fixed a leak at the heater hose on the firewall, I noticed that the temp. gauge now sits where its supposed to, rather than peak all the way to the red before the thermo. opens.

These engines must be really dependant on system pressure to maintain correct cooling.

So!!! If you have a slight pressure leak in the cooling system the temp. will do some pretty far out things.

Just something to think about guys! Hope this sheds a bit of light on the subject for some people.



"...we can rebuild him, we have the technology... we just dont want to spend a lot of money."

Posted: Sat Sep 03, 2005 3:00 am 
Getting Side Ways
User avatar

Age: 32

Posts: 1095

Joined: 10th Nov 2004

Gallery: 10 images

Ride: GU patrol, XH XR6, Isuzu Mux

Location: Mackay
QLD, Australia

after a good 2 hour drive the temp gauge settled down in mine after it was wondering after the HG change. so maybe the thermostat needed a good working to clear up.



' 96 Xh XR6 Ute
'96 DF LTD 6cy
'08 GU Nissan Patrol
'15 Isuzu MUX LST

Display posts from previous:
Sort by  
 Page 4 of 4  [ 49 posts ]  Go to page Previous  1, 2, 3, 4

Who is online

Users browsing this forum: Google [Bot] and 20 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Wed Oct 26, 2016 8:17 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names