Fordmods Logo

XG auto with 5TBD ECU 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: XG auto with 5TBD ECU
Posted: Wed Jul 15, 2020 3:29 pm 
Fordmods Newbie
Offline

Age: 54

Posts: 13

Joined: 3rd Feb 2017

Ride: XG Longreach

Location: Melbourne
VIC, Australia

1994 XG, XH XR6 motor fitted, with dizzy and log manifold. Changed ecu from 3ddb to 6TBA and turns but doesn’t fire. I had reset base timing to 0 btdc prior to installing 6TBA. Smart lock: interior light works and telltale displays as before on instrument cluster ie flashes regularly and off when cranking. Found fuel relay connector plug distorted by heat and changed both connector plug and relay with new.
Still not firing. Fuel pump can be heard when turning ignition on. Tried changing ecu to 5TBD EF or XH?
Turns over easier ?faster, but still doesn’t fire. Checked fuel lines connected correctly getting flow of fuel from fuel line into injector rail on cranking and traced back to filter. Getting fuel smell at exhaust so I reckon it’s getting to cylinders. Coil perhaps, or need to adjust dizzy perhaps. What is the ignition timing for the XH please? I have changed the thermo fan controller from Davies Craig mechanical to digital, getting rid of two relays that were connected to the fan control set up. Any input or ideas would be very appreciated, thanks.
Top
 Profile  
 
 
 Post subject: Re: XG auto with 5TBD ECU
Posted: Wed Jul 15, 2020 8:23 pm 
Getting Side Ways
Offline
User avatar

Age: 47

Posts: 778

Joined: 16th May 2012

Gallery: 16 images

Ride: EF-XR6/XG-6/XE-V8- project

Plankman wrote:
1994 XG, XH XR6 motor fitted, with dizzy and log manifold. Changed ecu from 3ddb to 6TBA and turns but doesn’t fire. I had reset base timing to 0 btdc prior to installing 6TBA. Smart lock: interior light works and telltale displays as before on instrument cluster ie flashes regularly and off when cranking. Found fuel relay connector plug distorted by heat and changed both connector plug and relay with new.
Still not firing. Fuel pump can be heard when turning ignition on. Tried changing ecu to 5TBD EF or XH?
Turns over easier ?faster, but still doesn’t fire. Checked fuel lines connected correctly getting flow of fuel from fuel line into injector rail on cranking and traced back to filter. Getting fuel smell at exhaust so I reckon it’s getting to cylinders. Coil perhaps, or need to adjust dizzy perhaps. What is the ignition timing for the XH please? I have changed the thermo fan controller from Davies Craig mechanical to digital, getting rid of two relays that were connected to the fan control set up. Any input or ideas would be very appreciated, thanks.


Fuel should be coming from the filter into the rail where the regulator holds that pressure and then returns to the tank,are you sure your fuel lines aren't connected backwards?

 

_________________

XG ute now powered with DOHC-BARRA 182/Tiger extractors/20% Underdrive and BA 4-SPEED + Tiptronic shifter

the-garage-f53/project-xg-fpv-dohc-barra-182-t128753-60.html

Top
 Profile  
 
 
 Post subject: Re: XG auto with 5TBD ECU
Posted: Thu Jul 16, 2020 12:19 am 
Fordmods Newbie
Offline

Age: 54

Posts: 13

Joined: 3rd Feb 2017

Ride: XG Longreach

Location: Melbourne
VIC, Australia

Thanks Johnny, I will recheck in the morning.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 29 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Oct 21, 2020 10:03 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names