Fordmods Logo

Fordmods Advertising

XH BBM Conversion Help Needed! 


Page 1 of 1 [ 1 post ] 

 Post subject: XH BBM Conversion Help Needed!
Posted: Thu Oct 13, 2011 2:51 pm 
Fordmods Newbie

Age: 25

Posts: 6

Joined: 14th Oct 2009

Ride: FG XR6 UTE

Location: melbourne
VIC, Australia

Hi, last weekend i have been doing what seemed to be a relatively easy conversion to my XH PVan by installing an EF BBM Intake Manifold,

i have installed the manifold and an RPM switch, the install all went ok everything fitted fine.

but when it came time to run the engine and set the RPM switch not so good, The engine starts and idles at 750rpm (where it used to with Log manifold) for about 30 seconds and then slowly dies right down to about 250rpm, from here it will run for a further 30 seconds and then either die or Rev itself back up to 750rpm and repeat itself.

Firstly i thought it was the MAP Sensor so i disconnected the tube that goes to it and started the engine, the engine then runs at 750rpm for as long as it wants but runs really rich and if i slowly put the tube back it runs fine for about 30 seconds and then dies.

Also if i even touch the throttle just a little bit the engine dies, i swaped the TPS with the old one but no luck.

If anyone has any ideas as to why it won't idle? and why it won't rev up? could someone please HELP!

Cheers Black_night
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: MSNbot Media and 29 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Sat Oct 22, 2016 2:38 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names