Fordmods Logo

xh headaches 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: xh headaches
Posted: Thu Oct 29, 2015 6:46 pm 
Oompa Loompa
Offline

Age: 28

Posts: 31

Joined: 26th Apr 2010

Ride: EB falcon S & EL XR6

Location: Cranbourne
VIC, Australia

hey guys i have an xh ute 6cyl auto

car has an au dedicated gas engine running on petrol and it is giving me a massive headache :evil:

engine starts and runs but very poorly it missfires extremely bad at idle and will not rev properly just seems to detonate, i have used all xh loom and sensors and ran the factory dizzy setup from the xh

engine used to run on lpg while in the car but not that well it would idle good but not rev past 4000rpm
i thought it was a gas problem so i changed the dead fuel pump, removed the lpg gear and ran the car on petrol form day one it has had this problem

i have checked plugs and all seems to be burning correctly

i have replaced:

plugs, leads, tps, dizzy because the module had problem, map sensor one the firewall and even an ecu, i have changed injectors twice one set of factory el ones and one set of au ones, O2 sensor

Im out of ideas, i have checked all leads and plugs and am getting a good strong spark at the plug, checked fuel pressure in the rail just on the off chance the reg was buggered, ive done a compression test on the engine all cylinders are within 10 psi, have also taken rocker cover off and checked cam timing which also was correct, and tried to set ignition timing i have it set at its best at the moment go either way and it runs worse, the car also wont go into diagnostic mode so i cant set base timing

if anybody has any answers please help even if the answer is burn it :D
Top
 Profile  
 
 
 Post subject: Re: xh headaches
Posted: Fri Oct 30, 2015 5:13 pm 
Stock as a Rock
Offline

Posts: 165

Joined: 3rd Sep 2008

Ride: XH

Location: . .
NT, Australia

squidgy wrote:
car has an au dedicated gas engine running on petrol and it is giving me a massive headache :evil:
...
i thought it was a gas problem so i changed the dead fuel pump, removed the lpg gear and ran the car on petrol form day one it has had this problem


Can you even run petrol in a dedicated gas engine? I thought they had different cams etc. Seems like taking the gas off made it a whole lot worse.
Top
 Profile  
 
 
 Post subject: Re: xh headaches
Posted: Fri Oct 30, 2015 8:25 pm 
Oompa Loompa
Offline

Age: 28

Posts: 31

Joined: 26th Apr 2010

Ride: EB falcon S & EL XR6

Location: Cranbourne
VIC, Australia

also forgot to mention sometimes when the car is in gear and you have foot on the brake and you pick up the idle just a fraction it seems to run perfectly fine which leads me to think there might be a vac leak somewhere

i do know that the have slightly different cam specs than the petrol ones and slightly higher comp but backing the timing off a fraction due to the higher comp should make it run ok even with factory timing set if its going to detonate it should only do it at high rpm under a lot of load not at 30 percent throttle right through the rev range
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 6:54 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names