Fordmods Logo

XH runs poorly with new coil and module 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: XH runs poorly with new coil and module
Posted: Thu Nov 12, 2009 8:11 am 
Stock as a Rock
Offline

Posts: 165

Joined: 3rd Sep 2008

Ride: XH

Location: . .
NT, Australia

I recently replaced the coil and module on my XH. The timing is good and it starts well, but it feels very different. The idle is bumpy, it seems to backfire a bit, it takes a while to fall back to idle and it is particularly unresponsive below about 2500rpm.

What can I do to fix this? I don't like spending money only to be worse off after the repair.

Thanks,
Tom
Top
 Profile  
 
 
 Post subject: Re: XH runs poorly with new coil and module
Posted: Thu Nov 12, 2009 8:44 am 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 863

Joined: 26th Nov 2007

Gallery: 20 images

Ride: XH Ute / AU3 V8 Wagon

Location: Bris-Vegas
QLD, Australia

This might sound like a silly question, but did you disturb/remove/disconnect the ICS (idle control solenoid) when you did the distributor module? Might be worth a 2nd look to make sure it's connected.
Good luck.
P.S. They are good fun to do, arent they?
:D

 

_________________

Yes, I own a Ute. No, I won't help you move!

EL Wagon Build Thread http://www.fordmods.com/the-garage-f53/sooty72-s-ef-futura-wagon-long-term-project-t90025.html
XH Ute Thread http://www.fordmods.com/post1138970.html#p1138970

Top
 Profile  
 
 
 Post subject: Re: XH runs poorly with new coil and module
Posted: Thu Nov 12, 2009 10:03 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 1634

Joined: 8th Jul 2007

Gallery: 21 images

Ride: EL F100 CAPRI XR EF

Power: 234 rwkw

Location: brighton
SA, Australia

also, what did u do when restting the timing. did u earth the pin and wait a minute or so till the idle dropped?
Top
 Profile  
 
 
 Post subject: Re: XH runs poorly with new coil and module
Posted: Thu Nov 12, 2009 10:25 pm 
Getting Side Ways
Offline
User avatar

Posts: 887

Joined: 8th Aug 2006

Ride: Falcon

Location: Central Highlands
QLD, Australia

DId you remove the dizzy when fitting the TFI module?

If so your timing might be out(running retarded), since your XH is basically an EL ecu you need to wait approx 2mins after shorting the top and bottom far left diagnostic pins. When the engine stumbles and nearly stalls(indicates static timing) Now you can set the base ignition timing too the mark on the timing cover.

If you didn't remove the dizzy I can't help you....

 

_________________

97 EL Fairmont 4l OHC .Silver.
Exhaust: Pacemaker's, 2.5" exhaust and Hiflow cat
Intake: FRAM AIRHOG , EL GT snorkel
XR6 300kpa fuel reg Stg 2 Auto Shift Kit.6DJA ECU
PM in Qld looking too buy Toyota 4*4 SR5 Dualcab Hilux 91-97 with 2.8l diesel engine/5spd manual

Top
 Profile  
 
 
 Post subject: Re: XH runs poorly with new coil and module
Posted: Thu Nov 12, 2009 10:38 pm 
Tyre Shredder
Offline

Age: 26

Posts: 371

Joined: 6th Jan 2009

Gallery: 21 images

Location: mackay
QLD, Australia

when driving
off the line does the engine stutter/ hesitate before reving?

 

_________________

xb falcon 500: currently being striped for full respray
ef falcon gli wagooon: currently finishing bodykit and then doors closed respray
the-garage-f53/ef-wagon-kit-pics-up-t77713.html

Top
 Profile  
 
 
 Post subject: Re: XH runs poorly with new coil and module
Posted: Thu Nov 12, 2009 11:51 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 3737

Joined: 22nd May 2006

Ride: BF F6 Tornado - #0077

Location: Bendigo
VIC, Australia

kelv_05ef_wagon wrote:
when driving
off the line does the engine stutter/ hesitate before reving?


mine does on occasion, mainly startups. any ideas?

 

_________________

** For Sale ** http://www.fordmods.com/ford-parts-for-sale-f17/assorted-e-series-parts-t124697.html

F6 Tornado 2006 Build

Is it about sex? The engine in my car? Or a cure for cancer?
No?

Then f**k off

Top
 Profile  
 
 
 Post subject: Re: XH runs poorly with new coil and module
Posted: Fri Nov 13, 2009 6:52 pm 
Tyre Shredder
Offline

Age: 26

Posts: 371

Joined: 6th Jan 2009

Gallery: 21 images

Location: mackay
QLD, Australia

it could be your auto on its way out?
intake mainifold gasket or your injectors leaking

 

_________________

xb falcon 500: currently being striped for full respray
ef falcon gli wagooon: currently finishing bodykit and then doors closed respray
the-garage-f53/ef-wagon-kit-pics-up-t77713.html

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 4:16 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names