Fordmods Logo

XH XR6 into EF GLi Conversion Trouble!!?? 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: XH XR6 into EF GLi Conversion Trouble!!??
Posted: Mon Apr 16, 2012 1:42 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 3

Joined: 4th Apr 2012

Location: Bundaberg
QLD, Australia

Conversion is going sh#t... I have a writen off XH XR6 ute 5spd and I have put it into my GLi EF ford sedan which was auto. I am currently running an XH XR6 ute manual ECU with EL auto wiring loom from the ecu through the fire wall to the engine bay (manifold etc) and to the gear box. I have the EF wiring loom in the dash to my BCM and all around there near the fuse box and steering wheel and sh#t, my BCM is out of the XH XR6 ute and also have bridged the nuetral switch and fixed up the reverse lights. When I try to start it the dash lights come on but it won't crank? No noises at all, no indication that it wants to try & start. The brake warning light comes on when I try cranking it? Battery is fully charged. When the motor was in the ute it started & ran fine. Even tried bridging the starter motor, nothing. I'm stuck. Where do I start?
Top
 Profile  
 
 
 Post subject: Re: XH XR6 into EF GLi Conversion Trouble!!??
Posted: Mon Apr 16, 2012 8:25 pm 
Technical Contributor
Offline
User avatar

Age: 38

Posts: 4093

Joined: 20th Mar 2005

Gallery: 2 images

Ride: 2.0 Turbo VW

Power: 142 rwkw

Location: Seaford State:
VIC, Australia

lemmie get this straight.

You have XH ECU, engine loom passenger side wiring.
and
EF Dash loom, Drivers side loom/Lights? and EF BEM?

I think I concidered this swap. iirc you need to run EL dash loom.
There are a number of things that run through the EF loom and one of those would be the thermo wirng (4 relay as opposed to 3 on XH/EL.)

See if you can clear up the details of what you have done.

 

_________________

Carefree, we may not be number one, but we're up there.

Top
 Profile  
 
 
 Post subject: Re: XH XR6 into EF GLi Conversion Trouble!!??
Posted: Tue Apr 17, 2012 12:21 am 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5589

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

^^^^ That's what I'm assuming Andrew.
Sounds like the starter relay isn't getting power.
Could most likely be wire mismatch between EF/EL looms - I'm guessing the starter relay line isn't wired through properly the EF BEM. Another one is the smartlock injector enable from the BEM to the ECU.
When you turn IGN on, the smartlock light should be on for a couple of secs, then go out.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
 Post subject: Re: XH XR6 into EF GLi Conversion Trouble!!??
Posted: Tue Apr 17, 2012 12:38 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 3

Joined: 4th Apr 2012

Location: Bundaberg
QLD, Australia

Managed to get it started. It was a loose negative from the battery lol I guess that's what happens when you have a few mates give you a hand & you don't double check everything.
But there is more problems:-
Turn the ignition to ON (NOT START) & the car starts but starter motor keeps winding? Have wired up a starter switch for now till I figure that problem out.
Also there is no tail lights?
Top
 Profile  
 
 
 Post subject: Re: XH XR6 into EF GLi Conversion Trouble!!??
Posted: Tue Apr 17, 2012 1:55 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 3

Joined: 4th Apr 2012

Location: Bundaberg
QLD, Australia

Ok. Tail light problem turned out to be the brake switch.

Have relised there is more to the ignition problem. As soon as the battery is hooked up there is constant power, by that I mean the fuel pump primes itself, the wipers can be used etc etc, without the ignition being turned on :?


EDIT: Did have the XH BEM in based on advise but have decided to put the EF BEM back in to see if that makes a difference
Top
 Profile  
 
 
 Post subject: Re: XH XR6 into EF GLi Conversion Trouble!!??
Posted: Fri Jun 01, 2012 8:47 pm 
Parts Gopher
Offline

Posts: 52

Joined: 7th Apr 2012

Ride: e series

Location: nsw
NSW, Australia

lol im starting the same conversion tommorow should be fun

i know i will have same dash wiring issues cant wait
Top
 Profile  
 
 
 Post subject: Re: XH XR6 into EF GLi Conversion Trouble!!??
Posted: Sun Jun 03, 2012 10:46 am 
Getting Side Ways
Offline

Age: 50

Posts: 912

Joined: 22nd Mar 2005

Gallery: 1 images

Location: FNQ
QLD, Australia

Good grief! Can the EF cam phase sensor not simply be bolted into the dizzy hole? - then fit EF coilpack and leads - no &^%ing with looms?

 

_________________

96 EF Auto GLi - Bilstein Shocks - Adjustable Front sway bar - JMM Cam - TI Perf J3 - TCI 2500/3000 stall converter. 2015 Jeep Cherokee Trailhawk.

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 23 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 9:04 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names