Fordmods Logo

BA - NO GAUGES, NO INDICATORS AFTER DISCONNECTING BATTERY 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: BA - NO GAUGES, NO INDICATORS AFTER DISCONNECTING BATTERY
Posted: Sat Jun 21, 2008 1:39 pm 
Oompa Loompa
Offline

Posts: 36

Joined: 13th Sep 2005

Location: Adelaide
SA, Australia

MY BA XR6 required repalcement of the drivers side headlight globe yesterday and as usual and has been done on several occassions previously I disconnected and removed the battery to access headlight.

On reconnecting I checked to ensure haedlights worked and that was that it sat in the driveway all noght until this morning when I hopped and statrted her. No gauges, no indicators, no backgrund illumination, no ICC screen. I diod however have headlights, tail lights, brake lights and the radio worked but you just couldn't see it.

I have checked and rechecked all fuses and can find no sign of any blown fuses. Changed over relays (swapped PWR Window one with ACC one) and this did not cure problem either.

Checked fuses in bonnet area and still no signs of blown fuses.

As you might imagine without gauges and indicators it becomes very difficult to drive as I have no idea of speed, fuel, temp, etc.

Anyone got any ideas? :(
Top
 Profile  
 
 
Posted: Sat Jun 21, 2008 2:58 pm 
Oompa Loompa
Offline

Posts: 36

Joined: 13th Sep 2005

Location: Adelaide
SA, Australia

Problem now solved. Thought about it a bit more then thought why dont I try disconnecting the cluster and reconnecting the plugs. Wouldn't believe it it worked!!!!

All gauges, ICC and indicators now working. Talk about crazy electronics give my first car any day a 1976 Chrysler Galant use to do my own plugs, points, oil, etc.

Still wouldn't giove up the Ford for anything.....yet!!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 6:01 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names