Fordmods Logo

CD player not working properly on 2000 AU 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: CD player not working properly on 2000 AU
Posted: Tue May 23, 2017 3:02 pm 
Fordmods Newbie
Offline

Age: 43

Posts: 1

Joined: 23rd May 2017

Ride: Ford AU 2000

Location: Buxton
NSW, Australia

I just got a 2000 AU and the CD player doesnt work properly. I will take the CD, look like it reading it, then spit it out. Radio works fine
Any ideas?
Or do I have to fork out a chunk to take it to the nearest dealership?
Top
 Profile  
 
 
 Post subject: Re: CD player not working properly on 2000 AU
Posted: Tue May 23, 2017 4:37 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3436

Joined: 11th Jan 2009

Ride: BA Falcon XT

Location: Smithfield
NSW, Australia

It is a normal occurrence for AU CD players. The best thing is to contact these people http://www.aslautomedia.com.au/repairs-exchanges/ford/
These people are the ones that are the official repairers for Ford Audio. Might pay you to chat with them and see what they can offer you rather than going all over the place trying to get an answer that will more than likely be wrong.
I had an AUIII with a bad CD player and was able to get a reco unit from ASL for $200.00 approx? but that was 3 odd years ago, give them a cal anyway. :)
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Oct 20, 2017 12:30 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names