Fordmods Logo

Installing a sound system in Ford FG | Amplifiers 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: Installing a sound system in Ford FG | Amplifiers
Posted: Mon Jun 09, 2014 6:38 pm 
Technical Contributor
Offline

Age: 26

Posts: 156

Joined: 3rd Nov 2011

Ride: 2009 XR6 FG N/A

Location: Townsville
QLD, Australia

I've started working on a new series of videos about how to install a sound system for the FG.
There are always lots of questions surrounding HOW to get a custom system set up in the FG, so hopefully I can answer those questions in this series.
I'll only be covering the basics in these videos, not the technical side of sound hardware.

For the technical side of this stuff check pyroay's threads on sound. They are full of great info and go into a great deal of depth when it comes to sound hardware.

The first episode is how to install an amp and set the basics of your sound system up so you can get ready to change your speakers, install subs or more amps.

https://www.youtube.com/watch?v=BVGgCu9y9y8

 

_________________

2dads XR6 FG Build

Top
 Profile  
 
 
 Post subject: Re: Installing a sound system in Ford FG | Amplifiers
Posted: Sun Jun 15, 2014 3:25 pm 
Parts Gopher
Offline
User avatar

Age: 27

Posts: 98

Joined: 30th Nov 2007

Gallery: 6 images

Ride: 06 BF XR6

Location: Portland
VIC, Australia

Had a quick watch and highly recommend fusing your power cable under the bonnet at the battery and not in your boot. The fuse on your power cable is to protect your cable in case of a short. The fuses in the amp are to protect them. If you damage the cable before the fuse its pointless and you will have a live wire. I understand your system isn't finished and you may plan to do this but its not a good point to put in the video.

 

_________________

Current car 2011 FG XR6 Ute Limited Edition

Past cars:06 BF XR6
97 EL

Top
 Profile  
 
 
 Post subject: Re: Installing a sound system in Ford FG | Amplifiers
Posted: Sun Jun 15, 2014 4:31 pm 
Technical Contributor
Offline

Age: 26

Posts: 156

Joined: 3rd Nov 2011

Ride: 2009 XR6 FG N/A

Location: Townsville
QLD, Australia

Yeah that issue has been raised and it's something that had completely slipped by me when I was planning the install.
I'll be address it in the next vid and obviously adding it as a note in the description to the original.
Can't be giving people information that has the potential to cause damage!

 

_________________

2dads XR6 FG Build

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 2:14 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names