Fordmods Logo

premo audio 

 

Page 1 of 1 [ 7 posts ] 

 
 Post subject: premo audio
Posted: Sun Jun 05, 2005 9:39 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 1954

Joined: 13th Apr 2005

Gallery: 2 images

Ride: eb falcon s series 2

Location: on welfare
NSW, Australia

well g'day guys

havent posted a topic in here for a while


what happens when u take a 92 eb with factory fitted premium audio (alpine)

and add a 15" venom sub?


jesus t i t t y f u c k i was surprised.


anyhow

what wattage is my amp??

also the front stage is pretty much f**k so i set the fader to the back and to the balance is in the middle.

ummm the bas is set to full and treble to nothing and on loud enough to cause the boot lid to rattle insanley it doesnt sound weak at all

i am super surprised and will probably get new h.u and amp for it all and new speakers all around.


anyways just posting about that question and tellin u peeps that u dont need to change anything to get a relatively good system if u just hack the sub onto the old sub line (if u have premium sound)

 

_________________

‮‮

Top
 Profile  
 
 
Posted: Sun Jun 05, 2005 10:33 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

so your running the venom off the premium amp? does the premo amp have controls to set what bass levels and that it sends to the sub? if not it might not be so good as the levels that the factory 8" can handle would difer to that of the new 15". just a thought.

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Mon Jun 06, 2005 12:53 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 5313

Joined: 6th Nov 2004

Gallery: 4 images

Ride: Surf, Turbo Diesel

Location: Melbourne, S.E Suburbs
VIC, Australia

i believe power output is 50x4
but 2 off them should be going to the sub (therefor 100w to sub)

 

_________________

Image

Top
 Profile  
 
 
Posted: Mon Jun 06, 2005 1:27 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 1954

Joined: 13th Apr 2005

Gallery: 2 images

Ride: eb falcon s series 2

Location: on welfare
NSW, Australia

100w to sub sounds more reasonable with the amount of noise im getting from it.

i also have it so no power is going to the front stage as its f**k (done with h/u not amp)

it works fine with the sub not getting much power cos the speakers are s**t and it balances out.....


when i get some more money ill replace all the speakers and head unit and amps and crap


cheers

thanks for the amp question answerage chunkz.

 

_________________

‮‮

Top
 Profile  
 
 
Posted: Mon Jun 06, 2005 1:34 pm 
Tyre Shredder
Offline

Age: 32

Posts: 386

Joined: 7th Nov 2004

Gallery: 4 images

Ride: falcon

Location: Melbourne
VIC, Australia

yeah,

the premo amp doesn't ahve fade control any control on the amp. But its pretty loud.

i have a 12" Pioneer running off my Premo Amp, and it shakes the boot lid no worries.

 

_________________

doing it in reverse with a fwd is like being fuked by a fat man and saying "well he has tits so i'm not gay"

Top
 Profile  
 
 
Posted: Mon Jun 06, 2005 2:50 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 1954

Joined: 13th Apr 2005

Gallery: 2 images

Ride: eb falcon s series 2

Location: on welfare
NSW, Australia

the amp itself i dont know where it is.

but my on/off button has like 600 controls lol


push it in for on/off


pull it out and spin and its right/left volumes.

theres also a little thing on it which pokes out a bit which u spin and it goes front/back volumes

 

_________________

‮‮

Top
 Profile  
 
 
Posted: Thu Jun 09, 2005 8:02 am 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 2705

Joined: 6th Nov 2004

Gallery: 11 images

Ride: 2009 FG XR6 Sedan

Location: Melbourne
VIC, Australia

not sure if many know this but the common sub is has a 4ohm impedance, the premo subs are a 6ohm thats why a different boxed sub works better.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 7 posts ] 

Who is online

Users browsing this forum: Google Adsense [Bot] and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 3:20 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names