Fordmods Logo

Au odometer lighting 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: Au odometer lighting
Posted: Wed Nov 23, 2011 9:34 am 
Stock as a Rock
Offline
User avatar

Age: 43

Posts: 143

Joined: 8th Sep 2010

Location: Sydney
NSW, Australia

Ive been playing around with my Au cluster. Has been fine till now when the odometer display wont light up . i can see the numbers if you look closely. first i thought it was the globes but just installed a different cluster and have the same problem. Is there a fuse or wire i should check out that anyone knows of ????
Top
 Profile  
 
 
 Post subject: Re: Au odometer lighting
Posted: Fri Nov 25, 2011 12:26 am 
Smokin em up
Offline

Age: 37

Posts: 262

Joined: 15th Aug 2007

Gallery: 3 images

Ride: Au fairmont seires I

Location: Sunshine coast
QLD, Australia

it could be the globes mate, as discussed on ebay? come visit my store and ill help you out with replacements

 

_________________

People hate the au series but i wouldnt have it any other way!!!

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 7:48 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names